1

I am attempting to connect Zabbix to a host and am getting the error:

Get value from agent failed: cannot connect to [[xxx.xxx.xxx.xxx]:10050]: [4] Interrupted system call

I am not sure why this error is occurring, I am able to ping both servers from one another and get a response with 0% packet loss. I also tried fping to the host server and get the response "is alive".

The agent is active and the log shows successful connection:

 13776:20150501:131459.326 Starting Zabbix Agent [TEMPO_PROD]. Zabbix 2.4.4 (revision 52334).
 13776:20150501:131459.331 using configuration file: E:\Program Files (x86)\Zabbix Agent\conf\zabbix_agentd.win.conf
 13776:20150501:131459.340 agent #0 started [main process]
 6440:20150501:131459.345  agent #1 started [collector]
 13376:20150501:131459.349 agent #2 started [listener #1]
 13864:20150501:131459.353 agent #3 started [listener #2]
 13720:20150501:131459.358 agent #4 started [listener #3]
 11996:20150501:131459.362 agent #5 started [active checks #1]

The Zabbix Server log does not show any refused connection either. Any ideas on how to resolve?

UPDATE:

Since the question has already been closed, but this may help others in the future:

I discovered that the host system was not in the same localized network as the Zabbix server, making communication impossible given the setup.

What I did to solve this: I used AutoSSH to create a permanent SSH tunnel between the host server and the Zabbix server. This allowed the agent and Zabbix server to communicate correctly.

4
  • use a zabbix-proxy.
    – Sirex
    May 13 '16 at 3:20
  • @Sirex The proxy wouldn't have solved this problem; it was a network-related issue. May 13 '16 at 3:23
  • I got to this page from google when looking to solve the same error message. What did autossh do for you that the proxy wouldn't ? I only ask because the proxy solves "I used AutoSSH to create a permanent SSH tunnel between the host server and the Zabbix server." Unless these are two entirely separate networks? In which case i'd just run the proxy through the ssh tunnel as it'll scale better in zabbix's UI and offloads the checks to the proxy.
    – Sirex
    May 13 '16 at 3:49
  • @Sirex The problem was due to the fact that my network(s) are very strict and ports 10050/51 were not opened and once they were, the routes were not clear because the connection passed through multiple zones. I had a Zabbix proxy installed on the machine, but it still could not connect because of the networking. Since Port 22 is usually open, auto SSH takes care of the routing issue for me. I can forward all traffic sent for my tunnel to the Zabbix trapper and agent ports as needed. May 13 '16 at 11:20
3

There can be many different reasons why Zabbix server cannot connect to Zabbix agent (wrong IP or DNS, wrong agent port, wrong item type, firewall, etc.), and many of these cases are described on the Troubleshooting page at https://www.zabbix.org/. Please try to check the suggestions there.

1
  • Thanks, I discovered that the problem was due to the network not being localized; I had to create a tunnel to connect the servers between the networks. May 1 '15 at 20:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.