1

Trying to install SQL Server 2012 (Eval) to work with the new BI tools using AdventureWorksDW tutorial. Therefore, I feel I've gotten bogged down in SA activities that would be done by others in the real world. I need help to get 2012 running.

What I've done:

I've verified firewall has SQLServer.exe. I've verified protocols for ShrMem, NmdPipes & TCP/IP are ENABLED. Depending I get one of two errors:

18456 Login; however, no named pipes (don't have the exact wording) This is the second install over last 4 days; and both time I hit the same wall. The first install I used Windows Auth; and then found a blog - SQL Coffee - that said to set up SQL Auth and check Mixed Mode bubble - which I did.

Under SQL Server Config Manager, SQL Server services in the right pane I click on SQL Server (MSSQLSERVER); I click and it pops up SQL Server (MSSQLSERVER) property box.

In tab "Log On" it has the following information:

Account Name: .\sqlacct Password: asterisked Confirm PW: asterisked Server Status: Running All the "helps" on the Internet - including MS - state to Start SQL Server Management Studio, and right-click on the database in Object Explorer. I don't have anything in Object Explorer (OE). When I click on the "Connect" drop down, I select "Database Engine" which pops "Connect to Server" dialog box which has the following in "Login" tab: (I've made no changes to "Connection Properties" or "Additional Connection Parameters" tabs.)

Server Type: Database Engine (greyed) Server Name: Name if PC Authentication: SQL Server Auth (I've tried Windows Auth, also) Login: (Tried each of the following): .\sqlacct | PC Name\sqlacct | sqlacct Password: same as on MSSQLSERVER noted above. Yep, multi-checked spelling/typing.

Since SQL Server 2012 is installed on SAME PC as the one that I'm developing through then my understanding is no ports are utilized. Therefore, I've not attempted any understanding of the ports.

0

From your description, it sounds like SQL Server is indeed running on the machine - if it wasn't, you would be receiving a different error message that says that SQL Server is not available. I think the problem is in the account you're using to login. (You can confirm that by looking up the "State" code listed in the error 18456 message in the log. The message shown to the user is always "State: 1" for security reasons.)

When you install SQL Server in mixed mode, you can set an administrator password; the username for that account is sa. You can also specify Windows accounts to have administrator access. If you do not select any Windows accounts on that screen, no Windows accounts will have access by default. (The service account cannot login to SQL Server unless you explicitly grant it access.)

Try this: Connect to SQL Server using SQL authentication, using username sa and the password you specified during installation. Once you've logged in, you can add additional Windows accounts, including your own.

0

enter image description here

Server name: Try (IP of the machine EX 192.168.2.69 or Try computer hostname, or try "computer_name\instance_name"

Login: SQL username or Windows Authentication

Password: ********

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.