0

I am trying to setup point to point networks between two Avila boards (Processor : XScale-IXP42x Family) running Openwrt( KAMIKAZE 8.09.1) and Linux kernel 2.6.26.8.

I am trying to setup two configurations : 1. AP-Client 2. Adhoc-Adhoc

I tried both but nothing seems to work. I am able to setup the respective AP, Client and Adhoc modes but they somehow don't associate with other peer. I am using madwifi(atheros) driver.

For e.g. - one configuration :

 iwconfig ath0
 ath0      IEEE 802.11g  ESSID:"wsid"  Nickname:""
      Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
      Bit Rate:1 Mb/s   Tx-Power:28 dBm   Sensitivity=1/1  
      Retry:off   RTS thr:off   Fragment thr:off
      Encryption key:off
      Power Management:off
      Link Quality=0/70  Signal level=-97 dBm  Noise level=-97 dBm
      Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
      Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Same thing happens when I use the Ad-hoc mode. It gets the configuration but Access point remains Not-Associated.

I would love to share more details but Can someone provide me some leads into this. I just want to ping one board from other.

Please help me migrate this problem on relevant forum in case it does not belong here.

Thanks

  • Why on earth are you using Kamikaze? That's utterly ancient and unsupported anymore. Use the current release (Barrier Breaker). – Michael Hampton May 2 '15 at 22:36
  • not sure but will that support the the older kernels with madwifi. I plan to use ubiquiti XR7 cards further and I found that this particular configuration supports it – Udit Gupta May 2 '15 at 22:52
0

Ok it worked finally. It seems like client mode definitely have some problem on older kernel but I am able to setup adhoc mode between two nodes. Only thing needs to be done is to forcibly put other machine into the cell of primary ad-hoc machine.

iwconfig ath0 ap <Cell Id of priamry Ad-hoc System>

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.