I've got a VPS running on Windows Server 2008 and I'm using Mailenable as an Email Server for POP3 and SMTP.

I've had the VPS since January 2015, its my first time configuring a server by myself, but I got everything running fine, and it was running fine until early April 2015 when suddenly I lost the ability to send emails to external domains, this turned out to be a reverse DNS PTR record, which got fixed by my Host and their ISP, and I was able to send email to external domains again.

Unfortunately a few days later it happened again, I couldn't send any emails to external domains, and I'm getting the exact same error as before.

I'm also unable to telnet to other servers on Port 25.

As said, the Reverse DNS PTR record is fine now, and as far as I know my DNS settings are fine but I could be wrong, I've been in discussion with my host and he has suggested disabling the firewall and seeing if that helped, but it made no difference. I also asked whether port 25 is blocked, but he assures me its open (Otherwise how would the email have worked earlier this year, and again for a few days after it broke the first time)

I've also had a look on websites that check open ports, and that also says port 25 is open.

My host doesn't believe its anything on their end, so its either a issue with the software, a DNS issue, or something else.

Below is the error messages in the SMTP log.

05/03/15 17:24:59   ME-I0018: [4A83B2DBC6C34BE390F54E05BD1B9CFE.MAI] Outbound message from ([SMTP:user@mydomain.com]) requeued as [35D6A01F07854658B00C126690661931.MAI] to the target domain [gmail.com]
05/03/15 17:24:59   ME-I0026: [35D6A01F07854658B00C126690661931.MAI] Sending message
05/03/15 17:24:59   ME-IXXXX: [35D6A01F07854658B00C126690661931.MAI] DNS resolved to the following record: IP Address=, Family=2, Type=1, Protocol=6
05/03/15 17:25:20   ME-E0038: [35D6A01F07854658B00C126690661931.MAI] Communications Error: Socket connection to gmail.com failed (error 10060). The host was either not contactable or it rejected your connection. Socket Family = 2; Host=; Port=25
05/03/15 17:25:20   ME-E0059: [35D6A01F07854658B00C126690661931.MAI] Message Delivery Failure. Attempt (0): Could not connect to mail server for domain (gmail.com). The remote mail server could not be contacted at this time. Message has been requeued.

I have an MX record set up for mail.mydomain.com, and an A record also set to mail.mydomain.com and my IP address, and the RDNS PTR record setup with my ISP also points to mail.mydomain.com and my IP.

I have tried using different software for SMTP and POP, but this also didn't work, so I don't believe its a software issue.

I have tried asking on the Mailenable support forums, but posts have to be approved by an admin for them to appear, and this takes a few days.

Any help would be greatly recieved. Thanks, Jamie

  • It certainly doesn't look like port 25 is open! – Michael Hampton May 3 '15 at 17:07
  • From all the reading I've done online i agree it sounds like port 25 is closed, but I've been assured it is actually open. I've looked at online port checkers like I mentioned in the opening post, and they say port 25 is open on the VPS IP, but I don't know how accurate they are. – Jamie Peters May 3 '15 at 17:28
  • Another update, upon recomendation from a friend i used Putty to see if I could telnet to the VPS IP on port 25, which was succesful, which implies port 25 is open. – Jamie Peters May 3 '15 at 18:12
  • Yes, but you're testing the wrong direction! – Michael Hampton May 3 '15 at 18:18
  • What else can I try? like I said above, I'm new to this, I've never looked after a server/VPS before – Jamie Peters May 3 '15 at 19:07

It does look like port 25 open outwards, but possibly not in the other direction, try a site like this http://www.mynetworktest.com/ports.php or this http://www.canyouseeme.org and test port 25 to your servers' external IP address. If it fails, you may have a firewall or ISP configuration issue still.

  • Just tried the first website from my phone to connect to the VPS IP on port 25 and it reports that port 25 is open. – Jamie Peters May 4 '15 at 10:41
  • Have you ensured that your DNS settings are the same as on the NIC or for the ISP? I imagine your ISP may have changed DNS servers, and thrown yours out... worth a try. forum.mailenable.com/viewtopic.php?t=17421 – Steven Fitzgerald May 6 '15 at 2:30

try Diagnostic Report

from MailEnable Management > Servers > Localhost > System > Diagnose

it gives you a lot idea about all kind of problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.