-1

Instead of //servername.domain.org:8080/appdir. I need //servername.domain.org.

How is this done? I want to truncate the URL dropping the :8080/appdir.

What's running on the server. Debian 7.8, Apache2.2, libapache2-mod-jk, Oracle's Java 7, Tomcat 7

Couple of documents I'm using as a guide. apache.org/docs/2.2/vhosts/examples.html digitalocean.com/community/tutorials/how-to-configure-the-apache-web-server-on-an-ubuntu-or-debian-vps

Based on what I've read in the DigitalOcean doc I've been modifying the /sites/enabled/000-default file.

Here's my vhost.domain.org file. /enabled sites/servername.domain.org

JkMount /* ajp13_worker ServerName servername.domain.org DocumentRoot /usr/share/tomcat/webapps/ ErrorLog /usr/share/tomcat/logs/error.log CustomLog /usr/share/tomcat/logs/access.log common Options -Indexes =======================================================================

I've tried this based on the "running different sites on different ports" from the Apache documentation. And a couple of other iterations that didn't work.

Listen 80 Listen 8080

NameVirtualHost 172.20.30.40:80 NameVirtualHost 172.20.30.40:8080

ServerName servername.domain.org DocumentRoot /usr/share/tomcat/webapps/appdir

ServerAdmin webmaster@localhost

DocumentRoot /var/www/
<Directory />
    Options FollowSymLinks
    AllowOverride None
</Directory>
<Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
</Directory>

ErrorLog ${APACHE_LOG_DIR}/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog ${APACHE_LOG_DIR}/access.log combined

============================================================================= /enabled sites/default-000 file in it's original form.

ServerAdmin webmaster@localhost

DocumentRoot /var/www/
<Directory />
    Options FollowSymLinks
    AllowOverride None
</Directory>
<Directory /var/www/>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
</Directory>

ErrorLog ${APACHE_LOG_DIR}/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog ${APACHE_LOG_DIR}/access.log combined

  • 1
    Check out mod_proxy in apache. – EEAA May 4 '15 at 22:09
0

The doc at this link provided a solution for me. http://tomcat.apache.org/connectors-doc/generic_howto/proxy.html I added this line to apache2.conf.
RedirectMatch ^/$ http://www.mycompany.com/myapp/ Stopped and restarted Apache2.

Now when I key in the url www.mycompany.com it takes me straight to the app.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.