0

I've created a simple webapplication running on an azure virtual machine. The application is also displaying data from another website (http, 80), hosted outside of the azure cloud but also under my control.

This worked now for about a year and suddenly stopped: I only see a timeout while the azure-hosted webapp is trying to connect to the other website.

1) The website outside of azure is online and reachable from any other machine I tried

2) The website outside of azure is NOT reachable in a browser within the azureVM: I only get a "ERR_CONNECTION_TIMED_OUT", a simple timeout

3) Other common websites are reachable from the azureVM

4) Firewall deactivated, still doesn't work

5) NSlookup from the azureVM to the domain outside WORKS and delivers the correct IP

I'm a bit puzzled, but maybe someone here knows what this might be and how I can fix it.

  • 1
    As you say you can't browse to the site through the VM's browser, the first thing I would do is do some network monitoring whilst using the browser and see what is coming back. – Sam Cogan May 6 '15 at 14:43
  • sry, only mentioned it in the headline: what I get is an "ERR_CONNECTION_TIMED_OUT", a simple timeout (added to the question now) – MADMap May 6 '15 at 15:03
  • How long does the page take to load from a machine that it does work on? Could it actually be timing out? – Sam Cogan May 6 '15 at 15:26
  • Thats VERY unlikely, the page which should be loaded outside from the azure cloud is a static 1.3k html page. It is a slow server, but the average load-time is about 20ms. – MADMap May 6 '15 at 15:50
  • If you do a tracert on the azure machine to the name (and IP) does it work? If not where is it failing? Is there any proxy settings setup on the Azure machine? – Sam Cogan May 6 '15 at 18:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.