0

This is a new installation. PostFix reports "550 5.1.1" "Recipient not found.", when users exist.

  • User can send email out everywhere.
  • Users can send email to each other through localhost.
  • All external emails to users return the 550 5.1.1 error message.

I don't see any errors in the maillog file. I think I have read every thread on this site with "550" in it, but not of the answers seemed appropriate. Does anyone know why known users are being reported as not found?

Here are my config files:

/etc/postfix/master.cf

# ==========================================================================
# service type  private unpriv  chroot  wakeup  maxproc command + args
#               (yes)   (yes)   (yes)   (never) (100)
# ==========================================================================
smtp      inet  n       -       n       -       -       smtpd
submission inet n       -       n       -       -       smtpd
#  -o smtpd_tls_security_level=encrypt
#  -o smtpd_sasl_auth_enable=yes
#  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
#  -o milter_macro_daemon_name=ORIGINATING
smtps     inet  n       -       n       -       -       smtpd
#  -o smtpd_tls_wrappermode=yes
#  -o smtpd_sasl_auth_enable=yes
#  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
#  -o milter_macro_daemon_name=ORIGINATING
#628      inet  n       -       n       -       -       qmqpd
pickup    fifo  n       -       n       60      1       pickup
cleanup   unix  n       -       n       -       0       cleanup
qmgr      fifo  n       -       n       300     1       qmgr
#qmgr     fifo  n       -       n       300     1       oqmgr
tlsmgr    unix  -       -       n       1000?   1       tlsmgr
rewrite   unix  -       -       n       -       -       trivial-rewrite
bounce    unix  -       -       n       -       0       bounce
defer     unix  -       -       n       -       0       bounce
trace     unix  -       -       n       -       0       bounce
verify    unix  -       -       n       -       1       verify
flush     unix  n       -       n       1000?   0       flush
proxymap  unix  -       -       n       -       -       proxymap
proxywrite unix -       -       n       -       1       proxymap
smtp      unix  -       -       n       -       -       smtp
# When relaying mail as backup MX, disable fallback_relay to avoid MX loops
relay     unix  -       -       n       -       -       smtp
    -o smtp_fallback_relay=
#       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq     unix  n       -       n       -       -       showq
error     unix  -       -       n       -       -       error
retry     unix  -       -       n       -       -       error
discard   unix  -       -       n       -       -       discard
local     unix  -       n       n       -       -       local
virtual   unix  -       n       n       -       -       virtual
lmtp      unix  -       -       n       -       -       lmtp
anvil     unix  -       -       n       -       1       anvil
scache    unix  -       -       n       -       1       scache

/etc/postfix/main.cf

#soft_bounce = no

queue_directory = /var/spool/postfix

command_directory = /usr/sbin

daemon_directory = /usr/libexec/postfix

data_directory = /var/lib/postfix

mail_owner = postfix

#default_privs = nobody

# INTERNET HOST AND DOMAIN NAMES
#myhostname = host.domain.tld
#myhostname = virtual.domain.tld
mydomain = [MYACTUALDOMAINNAME].com      
#myorigin = $myhostname
myorigin = $mydomain

inet_interfaces = all
#inet_interfaces = $myhostname
#inet_interfaces = $myhostname, localhost
#inet_interfaces = localhost

# Enable IPv4, and IPv6 if supported
inet_protocols = all

#proxy_interfaces =
#proxy_interfaces = 1.2.3.4

# See also below, section "REJECTING MAIL FOR UNKNOWN LOCAL USERS".
#
mydestination = localhost, localhost.$mydomain

unknown_local_recipient_reject_code = 550

# Specify "mynetworks_style = host" when Postfix should "trust"
# only the local machine.
# 
#mynetworks_style = class
#mynetworks_style = subnet
#mynetworks_style = host

# INTERNET OR INTRANET

#relayhost = $mydomain
#relayhost = [gateway.my.domain]
#relayhost = [mailserver.isp.tld]
#relayhost = uucphost
#relayhost = [an.ip.add.ress]

# REJECTING UNKNOWN RELAY USERS
#relay_recipient_maps = hash:/etc/postfix/relay_recipients

# INPUT RATE CONTROL 
# Specify 0 to disable the feature. Valid delays are 0..10.
# 
#in_flow_delay = 1s

#alias_maps = dbm:/etc/aliases
alias_maps = hash:/etc/aliases
#alias_maps = hash:/etc/aliases, nis:mail.aliases
#alias_maps = netinfo:/aliases


# DELIVERY TO MAILBOX
home_mailbox = Maildir/

# The mail_spool_directory parameter specifies the directory where
# UNIX-style mailboxes are kept. The default setting depends on the
# system type.
#
#mail_spool_directory = /var/mail
#mail_spool_directory = /var/spool/mail

#mailbox_command = /some/where/procmail
#mailbox_command = /some/where/procmail -a "$EXTENSION"

#mailbox_transport = lmtp:unix:/var/lib/imap/socket/lmtp

#mailbox_transport = cyrus


#luser_relay = $user@other.host
#luser_relay = $local@other.host
#luser_relay = admin+$local

#header_checks = regexp:/etc/postfix/header_checks

# FAST ETRN SERVICE
#fast_flush_domains = $relay_domains

# SHOW SOFTWARE VERSION OR NOT
#smtpd_banner = $myhostname ESMTP $mail_name
#smtpd_banner = $myhostname ESMTP $mail_name ($mail_version)

# PARALLEL DELIVERY TO THE SAME DESTINATION
#local_destination_concurrency_limit = 2
#default_destination_concurrency_limit = 20

# INSTALL-TIME CONFIGURATION INFORMATION
sendmail_path = /usr/sbin/sendmail.postfix

newaliases_path = /usr/bin/newaliases.postfix

mailq_path = /usr/bin/mailq.postfix

setgid_group = postdrop

# html_directory: The location of the Postfix HTML documentation.
#
html_directory = no

# manpage_directory: The location of the Postfix on-line manual pages.
#
manpage_directory = /usr/share/man

Here is the error message from GMail

Delivery to the following recipient failed permanently:

     [user@email.com]

Technical details of permanent failure:
Google tried to deliver your message, but it was rejected by the server for the recipient domain [domain.com] by smtp.secureserver.net. [68.178.213.37].

The error that the other server returned was:
550 5.1.1 <[user@email.com]> Recipient not found.  <http://x.co/irbounce>
  • Edit the question and add the maillog entry when rejection happened. – masegaloeh May 8 '15 at 13:46
  • There is are no /var/log/maillog entries with rejections. It only shows user log ins and disconnects. – rooter May 9 '15 at 15:18
  • Post the bounce email. Perhaps there is something wrong with MX record, so the email from outside can't reach your mail server*. – masegaloeh May 9 '15 at 15:34
  • Delivery to the following recipient failed permanently: user@emailaddress.com Technical details of permanent failure: Google tried to deliver your message, but it was rejected by the server for the recipient domain user@emailaddress.com by smtp.secureserver.net. [68.178.213.37]. The error that the other server returned was: 550 5.1.1 <user@emailaddress.com> Recipient not found. <x.co/irbounce> – rooter May 9 '15 at 16:29
  • @masegaloeh it was the MX record. I didn't set that part up and I put too much trust in the person that did. Thanks! If you add your comment as an aswer, I can mark it as correct. – rooter May 9 '15 at 17:27
1

Delivery to the following recipient failed permanently: user@emailaddress.com Technical details of permanent failure: Google tried to deliver your message, but it was rejected by the server for the recipient domain user@emailaddress.com by smtp.secureserver.net. [68.178.213.37]. The error that the other server returned was: 550 5.1.1 Recipient not found.

From the bounce above, looks like your MX record still pointing to GoDaddy email hosting: smtp.secureserver.net. Change your MX record so it points to your server.

More info: random Help Page on Internet and MX record wikipedia

0

You need to add your actual mail domain to the mydestination list, as it is currently only set to accept localhost:

mydestination = localhost, localhost.$mydomain, $mydomain

See the Postfix docs for details.

  • Thank you for the response. I had it that way initially, and one of the answers on this site told me to remove it. It didn't work. I reverted the change, so the line matches your suggestion, but the problem persists. – rooter May 7 '15 at 13:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.