2

I have a problem with users not being able to change their passwords.

When they try to change the password, they get this error:

"Your new password does not meet the length, complexity, or history requirements of your domain. Try choosing a different new password."

However, the password is definitely complex (20+ chars randomized numbers letters symbols etc), is not within hold period of one day.

The user has the permissions to change their password as you can see below:

enter image description here

I really don't see what could be the problem. Any tips?

1

This is probably because the password is too similar to one of the previous ones that are held in the history. Switch that option off and see what happens. It can be manipulated using the group policy editor (gpedit.msc).

  • Do you think this (3vQ4j*gC4Vrk5.h) can be similar to (Trololo$56!@) . I don't think so. – user2629636 May 6 '15 at 20:18
  • Have you had a look at the policy? – Konrad Gajewski May 6 '15 at 20:25
  • @user2629636 Is 3vQ4j*gC4Vrk5.h one of the last 12 (by default) passwords that the user had set? Change a character and find out. – Shane Madden May 6 '15 at 20:26
  • I've created the policy. Its a test user I created and those two are the actual passwords i tried. they are not similar. – user2629636 May 6 '15 at 20:28
  • 1
    Guys, I appreciate the help. But It's a test user I created to replicate the problem. It had only one password so far (the one I assigned while creating the account) and it's definitely not similar. Also, similarity is not a criteria, it has to be the same password, which obviously is not. – user2629636 May 6 '15 at 20:32
0

Can you provide a screen of your password policy settings? What is the setting for "minimum password age"? If that value is greater than 0, and that many days have not passed, you will be denied due to the age requirement.

  • Age requirement is "one day". I've tested this after 24 hours and on multiple brand new users. – user2629636 May 7 '15 at 19:27
0
  1. logon as a domain administrator

  2. click start administrative tools>Group Policy Management

  3. find the policy that deals with the password settings most likely the "defualt domain policy" right click then left click edit on the menu that comes up

  4. Computer configuration>windows Settings>security settings> Account Policies>Password Policy and change the minimum age to 0

    exit then click start>run and

type gpupdate, this make sure that the changes take effect.

Try to change the password again .

It works for me .

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.