0

I have a MongoDB running on a virtual server (Ubuntu 14.04.2 LTS). The MongoDB logs say this:

Fri May  8 13:08:02.270 [initandlisten] ERROR: Insufficient free space for journal files
Fri May  8 13:08:02.270 [initandlisten] Please make at least 3379MB available in /usr/lib/unifi/data/db/journal or use --smallfiles
Fri May  8 13:08:02.270 [initandlisten]
Fri May  8 13:08:02.270 [initandlisten] exception in initAndListen: 15926 Insufficient free space for journals, terminating

So I expanded the virtual disk another 50GB, but I'm still getting the same message. I restarted both MongoDB and the machine itself. I added the "smallfiles" option in the MongoDB config. When I cycle through all of the LVM commands (lvdisplay, pvdisplay, and vgdisplay), they all seem to say that the disk is big enough.

What am I missing?

4
  • 4
    resizing the actual filesystem? – lmz May 8 '15 at 21:28
  • Please share the output of: pvs, vgs, lvs, df -h, mount – Jakov Sosic May 8 '15 at 21:42
  • @JakovSosic Here are the outputs: pastebin.com/PUCPX4FE – mhashizume May 8 '15 at 22:38
  • @lmz is correct /dev/mapper/ubuntu--vg-root 6.5G 3.6G 2.7G 58% / – Mark Wagner May 8 '15 at 23:32
3

From your pastebin output, I think you should try running:

resize2fs /dev/mapper/ubuntu--vg-root

You can run this command without any downtime.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.