-1

I am having trouble re-installing PHP via yum on my server hosted by digital ocean.

I had PHP 5.4 installed but wanted 5.6. I added/enabled the remi repo's, ran yum -y remove php* and then tried to re-install php.

When I run yum -y install php I get the following:

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirrors.centos.webair.com
 * epel: mirrors.coreix.net
 * extras: mirrors.centos.webair.com
 * remi: remi.check-update.co.uk
 * remi-php56: remi.check-update.co.uk
 * updates: mirrors.centos.webair.com
 * webtatic: uk.repo.webtatic.com
Resolving Dependencies
--> Running transaction check
---> Package php.x86_64 0:5.6.8-1.el6.remi will be installed
--> Processing Dependency: php-common(x86-64) = 5.6.8-1.el6.remi for package: php-5.6.8-1.el6.remi.x86_64
--> Processing Dependency: php-cli(x86-64) = 5.6.8-1.el6.remi for package: php-5.6.8-1.el6.remi.x86_64
--> Processing Dependency: httpd-mmn = 20051115 for package: php-5.6.8-1.el6.remi.x86_64
--> Running transaction check
---> Package php.x86_64 0:5.6.8-1.el6.remi will be installed
--> Processing Dependency: httpd-mmn = 20051115 for package: php-5.6.8-1.el6.remi.x86_64
---> Package php-cli.x86_64 0:5.6.8-1.el6.remi will be installed
---> Package php-common.x86_64 0:5.6.8-1.el6.remi will be installed
--> Processing Dependency: php-pecl-zip(x86-64) for package: php-common-5.6.8-1.el6.remi.x86_64
--> Processing Dependency: php-pecl-jsonc(x86-64) for package: php-common-5.6.8-1.el6.remi.x86_64
--> Running transaction check
---> Package php.x86_64 0:5.6.8-1.el6.remi will be installed
--> Processing Dependency: httpd-mmn = 20051115 for package: php-5.6.8-1.el6.remi.x86_64
---> Package php-pecl-jsonc.x86_64 0:1.3.7-1.el6.remi.5.6 will be installed
---> Package php-pecl-zip.x86_64 0:1.12.5-1.el6.remi.5.6 will be installed
--> Finished Dependency Resolution
Error: Package: php-5.6.8-1.el6.remi.x86_64 (remi-php56)
           Requires: httpd-mmn = 20051115
           Installed: httpd-2.4.6-31.el7.centos.x86_64 (@base)
               httpd-mmn = 20120211
               httpd-mmn = 20120211x8664
               httpd-mmn = 20120211-x86-64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I have been following this tutorial: https://www.mojowill.com/geek/howto-install-php-5-4-5-5-or-5-6-on-centos-6-and-centos-7/

I'm a bit stuck. I have tried removing httpd, re-installing httpd, nothing seems to fix this. I even get the error when I disable remi and try and install PHP 5.4.

Any ideas on where to go from here?

I am running CentOS Linux release 7.1.1503 (Core)

I think this could be an issue to do with repositories because I was able to install php56 on a fresh server without any issues at all.

1

You're running EL7, but you installed the remi repostiory for EL6. Install the correct repo and try again.

  • I removed all of the repo's apart from centos ones and then following this tutorial: webtatic.com/packages/php56 I got this result: pastebin.com/y8snscmt – Tom Wright May 10 '15 at 22:55
  • If you want to go off and do your own thing, that's fine, but then why ask the question? – Michael Hampton May 10 '15 at 22:57
  • Sorry Michael, I did read it. I'm not great at Linux and I thought you meant I had installed the wrong version of epel. I am grateful for your help... – Tom Wright May 10 '15 at 23:04
  • I managed to get EL7 installed and it still wasn't working. After that I tried a yum clean, yum update then removed httpd, installed it again and then php56w was able to install. Thank you for your help! – Tom Wright May 10 '15 at 23:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.