I've been mucking around with NAS solutions over the weekend and have run into problems with both FreeNAS and OpenFiler which have ground me to a halt, so I'm seeking some help here.

OpenFiler simply won't install on my hardware (a new SATA system) with an error I think trying to see the SATA CD drive once it gets past the initial boot, and with a video error once I boot from an external USB CD, so I gave up on it (pity as I'd rather the linux alternative, given that I know linux).

I managed to get FreeNAS up from the CD and initially put the configuration on the first disk in the system. This turned out to be a mistake, because I couldn't then use the disk in the raid array I want to build on this machine.. no biggie.. just remove it and started again.

The problem is that every time I try and put either the entire system on an external USB key it fails to boot correctly (goes as far as needing to find the mountroot but fails there) or save the config from the CD boot to the key, it fails to work correctly, and I have to re-configure after a reboot.

The system registers the key correctly and gives it a drive letter.. but that's it.. nothing seems to work.

I tried writing the system to the key using both dd and using the menu option but I get the same result each time.

Now.. the reason I'm asking here and not on the freeNAS forum, is that for some reason I can't convince the freenNAS forum that I should be able to post questions (no idea why), but anyway.. I'm here now..

Thanks guys..



you can use these link: http://sourceforge.net/apps/phpbb/freenas/viewtopic.php?f=38&t=1944 it works flawless and i think the best solution for your issue.

  • Thanks for this... its basically the procedure I was having problems with. I've ended up giving up on that and have it working by using the CD to boot and USB to store the state. Not a great solution, but it works. It seems to be pretty hit and miss for some reason. – Peter Nunn Oct 17 '09 at 22:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.