1

I have a shared excel file stored on a server that continually results in "This file is locked by "another user". Do you want to open as read-only?". This is on a Windows 2003 R2 Server and has had all the relevant patches and updates applied. Most users accessing this are using Microsoft Office 2010. I have looked into the relevant patches and this has not assisted. Here is some information on the server

  1. Microsoft Windows Server 2003 R2 - Enterprise Edition with Service Pack 2 (These will be virtualised and updated to Windows Server 2008/12 in the long run)
  2. Intel(R) Xeon(R) CPU E3-1270
  3. Automatic Updated - Daily at 12.00pm (Server probably requires reboot for these to apply)

Within the server manager if I look at "Open Files" and sessions, I am unable to see if this file is open, which leads me to believe it an issue either with the client PC or security. I am trying to use a command line tool to check for Open Files.

The first question I have is regarding openfiles.exe. I am able to successfully run the command like so:

openfiles.exe /query /s thissvr /u domain\me /p password /fo csv >>C:\OpenFilesSvr1.csv

The command I run is a little more than listed, but basically I am able to extract the CSV, format as a table and identify the file. Until the relevant fix is applied I have just compiled the BAT for the user to run to be able to identify the user in it. This is not optimal. Is there a method to better target files in this, without disconnecting them?

I have now also noted that the pop-up on the user's screen states one user has the lock on the file, however the server and openfiles.exe state another user. Alot of the forums I see where are the options to save the file as an alternate name and then overwrite, disable the preview on explorer etc. however this is not assisting. One a Microsoft Blog I can see their resolution is as follows:

NOTE: Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps. Quit all instances of Word. To do so, follow these steps: Save all your work, and then quit all programs. Press CTRL+ALT+DELETE to open the Windows Security dialog box. Click Task Manager, and then click the Processes tab. Click Winword.exe, and then click End Process. In the Task Manager Warning dialog box, click Yes.

If you receive a message that states that the program is not responding, click End Now. Repeat steps d and e for each occurrence of Winword.exe. On the File menu, click Exit Task Manager. Start Windows Explorer, and then browse to the folder that contains the document file that you tried to open when you received the error message. Delete the owner file.

The owner file is located in the same folder as the document that you tried to open. The owner file name uses the following convention: It begins with a tilde (~), followed by a dollar sign ($), followed by the remainder of the document file name. The file name extension is .doc. For example, the owner file for Document.doc is named ~$cument.doc. Start Word. If Word asks you whether you want to load the changes that were made to the Global or Normal template, click No. Open your document.

I do not consider this a correct fix as it does not assist the user. Because of the importance of this file server and the roles it hosts I do not wish to play around with it too much, so I have tried as many work-a-rounds as I could have done so far with no luck. I would appreciate any fixes you have faced before as this is now hindering the business.

Update on this question

I have now noted that this is occurring on multiple severs we have running. The first thought I have would to be remote these servers to apply changes, updates and fix any of those odd locks they get themselves into. The issue here is that these servers are doing what they're designed to do- be up all the time for access. I will need to look into the option of performing a reboot on the devices to see if this assists.

I have done some looking around and might take my look away from user locks and transfer to possible system locks, Handle or PsFile will assist with this. I do not want to rely on third party applications but will test Unlocker.

Let me know if there is anything you would advise.

0

There are two ways in which your excel file can be locked - it can be 'in use', as in another process has an open handle to the file, but also Microsoft Office uses special 'lock files' (called 'owner files' by Microsoft).

The owner file is located in the same folder as the workbook that you tried to open. The owner file name uses the following convention: It begins with a tilde (~), followed by a dollar sign ($), followed by the remainder of the workbook file name. The file name extension is .xlsx. For example, the owner file for Sheet.xlsx is named ~$eet.xlsx.

The owner file is hidden, so you will need to enable 'view hidden files and folders' to view it. If the owner file is present then you can simply delete it to 'unlock' the file.

Further information and troubleshooting procedures are listed on the Technet blogpost The definitive locked file post

  • Thank you for the information. In regards to the hidden files being opened they are present. I do not mind the file being locked, I am trying to figure out how the end users can see who has the file locked. The end client is unable to "unlock" the file because they need to call when they want to know who is in it. Background Info: Over 2000 staff at over 100 sites. – DankyNanky May 14 '15 at 22:52
  • So work through the linked article... 2003 goes end of life in two months anyway. – BlueCompute May 15 '15 at 8:21
  • Firstly the steps you linked I already have in the blog, so it's uh..useless. Secondly that is not a fix, that's just oh move on. Good answer however. It was really, uh, unproductive. – DankyNanky May 15 '15 at 8:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.