0

I installed Synology DSM 5.2 yesterday, because it's stable release came out.

Afterwards I installed and configured Docker, MariaDB and the gitlab from the official Synology repo.

Gitlab is running on ort :30000 and the ssh access for gitlab is running on port :30001

The Docker container is running, but whenever I try to access the Docker Website:

https://example.org:30000

=> I get SSL errors in FireFox

An error occurred during a connection to example.org:30000. SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long)

=> and Chrome:

SSL connection error

ERR_SSL_PROTOCOL_ERROR

Which can indicate an unencrypted connection (http-only) over this port and the DSM enforces HTTPS protocol somehow.

I use an officially signed and verified certificate, which works flawless in the normal DSM Webinterface, Webdav and webservices like DokuWiki.

Has someone experienced a similar problem or even found a solution. Google seems empty on the topic of Synology DSM 5.2 Docker/Gitlab SSL errors.

  • 1
    the package as it is installed via sinology package manager does not provide on open port 443 of your GitLab docker instance, only Port 80 is mapped to port 30000 of you DS, you would need to roll your own installation via docker using your own certificate while configuring SSL, something like: docker run --name=gitlab -d \ --env='GITLAB_HTTPS=true' \ --volume=/srv/docker/gitlab/gitlab:/home/git/data \ sameersbn/gitlab:7.10.4 – HolgT May 20 '15 at 14:52
  • Exactly, that's how I got it running. :) – sweisgerber.dev May 21 '15 at 11:50
1

My IT infrastructure enforced SSL via HSTS for the Subdomain, the Synology was running on. HTTP access worked for the gitlab Docker image, after HSTS was disabled.

HSTS on the Synology itself was also disabled.

Enabling SSL for the GitLab Docker container (from Synology) is not possible. Gitlab is distributed as installable package for DSM 5.2 and is HTTP only without SSL encryption. You cannot even enable it, because the docker container settings are not editable. If you set up your own Docker Container, you can enable SSL, supply your Certificate and you are fine.

After I configured my own Docker container with new MariaDB credentials, mail settings and SSL certificate, it worked even with enabled HSTS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.