0

How to fix the error of stdout capture being missing. I am scheduling couple of tasks, initially they are running fine after couple of iteration it is throwing this error.

enter image description here

  • What did Ansible support say? – EEAA May 13 '15 at 16:40
  • I haven't spoken to Ansible support yet. I was thinking this would be very trivial and have an easy fix. I will speak to Ansible support – Naveen Vijay May 13 '15 at 16:55
1

I reached out Ansible Support and apparently they acknowledged that the Tower Version which I was then using [ 2.1.3 ] had some bugs and they recommended to upgrade to 2.1.4 solved the issue.

Update : More to it, I was using Instance size of t2.micro - which they recommended to use an instance with higher Memory Capacity - running that with m3.medium did the trick.

Ansible Tower 2.1.4 - Download Link

|improve this answer|||||
0

"stdout capture missing" typically means the Tower job failed before it got properly started. That can happen with gross misconfiguration or yml format issues. I think I've seen it with bad job template vars too.

The job info page should explain what happened. If not, you can hit up the API: /api/v1/jobs/123/

|improve this answer|||||
  • I have spoken to Ansible Support and they are currently looking at my sosreport. I get the same error even if I do a straight forward - SCM GIT Update, so I am thinking there is somewhere - not just with playbooks – Naveen Vijay May 14 '15 at 1:20
  • make sure to answer your own question when you figure it out- that way it'll help others in the future. sudo servicectl status may show a service that isn't running (though that may not help in Tower 2.x). – tedder42 May 14 '15 at 1:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.