2

I want to administrate Samba 4 (Active Directory) via RSAT (Remote Server Administration Tools) using Windows 7. I have installed the RSAT and opened the "Active Directory Computers and Users" tool in Windows 7, but occurs this error:

Naming information cannot be locate because:

The specified domain either does not exist or could not be contacted.

Contact your system administrator to verify that your domain is properly configured and is currently online.

I am logged in domain using a Domain Administrator User.

When I run dcdiag to debug Domain Controller, I get this error:

{COMPUTERNAME} is not a directory server.

It was not possible locate local server

Can anyone help me?

1

check DNS setting on your win7 machine, check that you could reach at least one domain controller by dns, ip. I think RSAT failed to contact domain controllers because of DNS issues.

Also try use NETBIOS domain name: domain, and FQDN of the domain controllers.

  • The logged Domain Administrator User in Windows 7 gets IP by DHCP, and the DNS and GATEWAY assigned are the same. I can ping DNS, GATEWAY, as well FQDN (it is the GATEWAY/SERVER name, and it is the same SERVER that assigns DNS). – Marco May 13 '15 at 21:44
  • Just to make clear that this solution does not worked. Still awaiting other solutions. – Marco May 18 '15 at 21:17
-1

An old question, but here is the answer:

Really don't know why my RSAT didn't want to connect on Samba-AD-DC automatically although I was logged as Samba Administrator on my PC, tried so many things but unsuccessful.

Solution was: Open "Active Directory Computers and Users", ignore error and in Action tab choose "Change Domain Controller", enter IP address of your domain controller and that's it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.