5

Starting this morning it takes 3-4 seconds to start even very simple PowerShell script on my machine. This command shows 3.2-3.4 seconds on my machine and only 0.4 second on co-worker's machine.

powershell ( Measure-Command { powershell "Write-Host 1" } ).TotalSeconds

I know there are thousands of possible reasons (including viruses!)... But I don't see any suspicious activity on my machine, and I've installed a bunch of Windows updates this morning, and it was the only significant change in my environment.

I'm wondering if anybody has the same problem.

  • Anything in your $profile which might load modules or perform other lengthy tasks? – jscott May 13 '15 at 22:18
  • "powershell -NoProfile ..." gives me the same results... – Sergey Popov May 13 '15 at 22:29
  • run a processmonitor and watch where you loose time, if loading something on disk in example. – yagmoth555 May 14 '15 at 1:43
3

It seems like updates described in the following KB article lead to the problem:

https://support.microsoft.com/en-us/kb/3057134

I uninstalled these updates and the problem disappeared, I installed them again and the problem came back (tested both on Win 8.1/PS4 and Win 7/PS3).

Thank you all guys for your suggestions!

0

I ran your command on my powershell & it took 3.21 seconds the first time. Second time & further ones took 0.65 seconds. I'm running ps 4.0. I've also had my console session opened for a few days. Do you and you co-worker run the same ps version? Same hardware? Have you tried the dreaded reboot?

  • Yes, we run the same version (3.0) and I've reboot my machine. I also tried other machines, including virtual machines. The virtual machine which is running on my computer and which was not updated recently show me 0.4 seconds for this command. And it seems like on these machines which were updated this morning this command runs significantly longer. – Sergey Popov May 13 '15 at 22:29
  • Do you re-run the command again in the same session to see if it's changed. I assume you have but just checking. Well you seem to think the updates might be the culprit. I haven't done updates today but you could try to uninstall the updates from today and see if that speeds things up. – Jon May 13 '15 at 23:01
  • Thank you, Jon! It seems like I was able to identify the update which caused the problem. – Sergey Popov May 14 '15 at 12:45

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.