2

this is a conceptual question I guess, considering I already fixed the issue, but the problem is, I'm not quite sure what the issue is.

I was trying to connect to a new VPS I setup, and made an ssh_key for root, ssh'd in, and then made a new user with a pw, then ssh'd him in. Then tried to connect using netbeans and it failed. Then I tried a cloud IDE, 'codeanywhere' a google chrome extension, and that worked fine. After some googling found this question

https://stackoverflow.com/questions/26424621/algorithm-negotiation-fail-ssh-in-jenkins

and the suggestion of adding

TL;DR edit your sshd_config and enable support for diffie-hellman-group-exchange-sha1 and diffie-hellman-group1-sha1 in KexAlgorithms:

KexAlgorithms curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group14-sha1,diffie-hellman-group-exchange-sha1,diffie-hellman-group1-sha1

worked, and netbeans now connects.

My question is: Why did the other things work and not netbeans? I barely understand connection algorithms but we were talking about them at work the other day, is it just that netbeans doesn't have them all? Or is my VPS setup incorrectly? Just seems weird to me, that ssh from command line (MacOSX) and the chrome extension had no problem but netbeans did.

thanks

2

Based on your problem description it would appear that Netbeans includes an ssh client which only supports these older key exchange algorithms that modern OpenSSH server versions do not have enabled by default.

The normal ssh client installed on your system, however, does support some key exchange algorithm that is enabled by default on the OpenSSH server.


Without even investigating I think it would be a reasonable assumption that the change of enabled algorithms was most likely done for a reason and that you're probably making a security trade-off when re-enabling these algorithms for increased compatibility.

Looking up the relevant commit, it does appear that this assumption is correct.

  • Thanks! @Håkan Lindqvist , I probably need to either update Netbeans 7, or download 8. – FunBeans May 16 '15 at 16:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.