2

I've thrown myself into learning Hyper-V and Server 2012 over the past week or so, and I'm working on setting up a virtualized WDS/MDT server using Hyper-V. I'm having an issue managing/understanding the way the virtual switch works, and I've been unable to find a proper answer for my issue.

Currently, my box is set like this (with one physical NIC):

  • Server 2012 (host) with Hyper-V and DHCP roles installed (dhcp scope as 192.168.1.3 to .254)
    • Server 2012 (guest) with WDS & MDT installed. (static to 192.168.1.2)

I've set up a virtual switch as external, and bound it to the physical NIC. The issue I have is with the IP address of the host. When I look at ipconfig on the host, my physical adapter has a 169...* address. My guest OS has no problem pulling an IP from the host DHCP server, nor do any other physical machines connected to the (unmanaged) switch.

The question I have is, is this working as intended? Another lab running VMware allows me to set the guest connection as bridged, and I'm able to manage both the host and guest with a single NIC, I'm just not sure how to do this in Hyper-V. I'm unable to manage the host server from another device on the network, which I imagine is wrong. Do I need two NICs, one dedicated to the guests and one dedicated to the host to have this work the way I want?

3

It sounds like you didn't enable the Allow management operating system to share this network adapter setting on the virtual switch. With a single NIC you'll need to enable this on the virtual switch so that you can assign an IP address to the virtual Ethernet adapter that will be created once this setting enabled, which is the ip address that you'll connect to the host with. Otherwise you'll have no network connectivity to the host itself.

enter image description here

enter image description here

| improve this answer | |
  • I'm not at my lab until tomorrow, so I can't say for sure that I have this checked, but I'm pretty sure I have it enabled. I'm able to manage the virtual adapter in the host's ncpa.cpl (and the guest picks up on those settings), but ipconfig on the host still gives me a 169 address. Should I just ignore that? I'm able to ping through to the guest from other nodes on the network, so the connectivity is there (somewhere). – John May 17 '15 at 15:53
  • Guest connectivity and host connectivity at layer 3 aren't related to each other. The physical NIC that the virtual switch is bound to is merely a "bridge" to the physical network (at layer 2) and doesn't have anything to do with host connectivity to the network (at layer 3). If you've already got that setting enabled on your virtual switch then my guess is that the problem is that the server is configured to obtain it's ip address from DHCP (from itself), which is probably where the problem is occurring. You should assign a static ip address to the server. – joeqwerty May 17 '15 at 16:02
  • I initially configured the physical ethernet adapter with a static IP, however when I make the virtual external switch, it strips all the settings I put on the physical adapter and puts them onto the virtual adapter. Everything I've read said this is supposed to happen, and the management is done on the virtual adapter, as the physical adapter has only Microsoft Virtual Network Switch Protocol (I think that's what it's called off-hand) available. The virtual adapter on the host has a static IP, and the physical adapter is unmanageable due to the above (as far as I know). – John May 17 '15 at 17:25
  • Yes, that's all correct and as it should be based on your scenario. Can you post the output of ipconfig/all from the host? – joeqwerty May 17 '15 at 17:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.