4

I am trying to demonstrate the usefulness of docker. I have been able to build images and show prototypes on my work laptop running windows 7. However I now need to move the docker image unto a server. Currently, the only server I have access to is windows server 2008 r2 running through VMware. I'm hitting a wall because of VMs running inside of VMs. Has anyone been successful in a similar environment?

Update: Added more details of the problem When I run boot2docker, it fails with the following:

initializing...

starting...
error in run: Failed to start machine "boot2docker-vm": exit status 1

I then went to the VirtualBox Manager and tried to manually start the VM and it fails with the following:

Failed to open a session for the virtual machine boot2docker-vm.

VT-x is not available. (VERR_VMX_NO_VMX).

Result Code: E_FAIL (0x80004005)
Component:   Console
Interface:   IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}
  • 1
    What wall are you hitting, ESXi is perfectly capable of running nested virtualisation - what version of ESXi are you using and what are your CPU/s make and model? – Chopper3 May 18 '15 at 18:35
  • I'm told we are running ESXI 5.5 – pgreen2 May 18 '15 at 18:54
  • 1
    @Chopper3 ESXi doesn't fully support being nested until 6.0. 5.5 has some partial support but VMware won't talk to you about it unless you're on 6.0. – Michael Hampton May 18 '15 at 19:04
  • @MichaelHampton so is your best guess that this isn't possible? – pgreen2 May 18 '15 at 20:35
  • It may not be supported but I've ran three levels of nesting with ESXi 5.5u2d - @pgreen2 - that is the actual wall you're hitting? have you tried this or are you just guessing? – Chopper3 May 18 '15 at 20:48
4

Based on the comments, I was able to ask the correct questions to our operations team. The belief is docker can run on windows server 2008 r2 running on vmware ESXi 5.5, but it requires hardware version 9 or 10, but we are running 8 which is causing the problems.

Details of running nested VMs with vmware is discussed here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.