0

Everything worked great for a year, and the server was untouched. All of a sudden my automation file transfers depending on Dropbox didn't work anymore. The dropbox tray icon is unavailable so I try to run the daemon and get segmentation fault. So I tried to reinstall:

$ rm -rf ~/.dropbox
$ cd ~ && wget -O - "https://www.dropbox.com/download?plat=lnx.x86_64" | tar xzf -
$ ~/.dropbox-dist/dropboxd

And still get segmentation fault, how do I fix this?

strace output: https://gist.github.com/anonymous/6f0151e86665bc6842c8#file-gistfile1-txt

closed as off-topic by fukawi2, Andrew Schulman, dawud, kasperd, Cristian Ciupitu Jun 10 '15 at 23:58

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions should demonstrate reasonable business information technology management practices. Questions that relate to unsupported hardware or software platforms or unmaintained environments may not be suitable for Server Fault - see the help center." – fukawi2, Andrew Schulman, dawud
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    This is not an appropriate use of Dropbox. Use git or some other reasonable deployment strategy. – Michael Hampton May 20 '15 at 6:11
  • uninstall dropbox, time to try a good old version of bittorrent sync – Level1Coder May 20 '15 at 6:29
  • I said reasonable. – Michael Hampton May 20 '15 at 6:31
  • Maybe you must run daemon with root user? – mvillar May 20 '15 at 6:32
  • run daemon as root user failed – Level1Coder May 20 '15 at 7:09
0

Interestingly enough, I increased the physical RAM from 4GB to 8GB, and Dropbox is starting up without segmentation fault anymore.

Not the answer you're looking for? Browse other questions tagged or ask your own question.