Getting a really wierd error.

One of the developers tried to install Windows 2008 as a Virtual PC. He has also run windows update.

When he tries to install dotnet framework 3.5 SP1 he gets the following error:

[09/25/09,12:48:26] Microsoft .NET Framework 2.0SP1 (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 2.0SP1 (CBS). MSI returned error code 1 [09/25/09,12:48:34] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0SP1 (CBS) is not installed.

I though that dotnet framework was installed automatically with windows update on windows 2008. So how could it be missing?




We also have the same problem on a VPC that had dotnet framework 3.5 installed and working OK.

I have tried removing all versions of dotnet framework, using the following clean up tool: http://blogs.msdn.com/astebner/pages/8904493.aspx

I then downloaded and tried to install dotnet framework 2.0 SP1, from this location: http://www.microsoft.com/Downloads/details.aspx?familyid=79BC3B77-E02C-4AD3-AACF-A7633F706BA5&displaylang=en

The error I now get is:

"This product is not supported on the Vista Operating System"


Thanks for the help, have given an up vote to everyone.

In the end our problem was that we had installed Windows Server 2008 from an older ISO image, on this everything worked fine untill we tried to install framework 3.5 SP1. We reinstalled Windows from a new image, and it worked OK.


Normally you just need to make sure that you have .NET installed and then Windows Update will lead you through all of the update. However I've run into failures like yours on about 1 in 50 servers, so the trick is to figure out the best path to navigate for your situation.

You're on the right path. Here's what I suggest:

For the WS08 server, I would uninstall the .NET Framework completely and then build back up again. To do so, use Add/Remote programs to uninstall any of the service packs that you see there. Then from Server Manager go to -> Roles -> Web Server (IIS) -> Remove Role Services -> and remove "ASP.NET" and ".NET Extensibility" (and accept the prompt to remove dependencies). After that completes, perform a reboot if it asks for one.

Then, from Server Manager again, add a role service and add those back again. Then use Windows Update, but step through the service packs in order. Don't assume that the cumulative installs will work since you already know that you're a fringe case.

For the Vista computer, if you haven't already, I suggest the Windows Update path there too. If that dead-ends, then start here: http://www.microsoft.com/net/Download.aspx. Make sure that you do have .NET 2.0 installed. (just check c:\windows\microsoft.net\framework\v2.0.50727 and make sure it has the full set of files.).

Then install 3.5 (not SP1 yet): http://www.microsoft.com/downloads/details.aspx?FamilyId=333325FD-AE52-4E35-B531-508D977D32A6&displaylang=en

Finally 3.5 SP1: http://www.microsoft.com/downloads/details.aspx?FamilyId=AB99342F-5D1A-413D-8319-81DA479AB0D7&displaylang=en

Hope that helps.


THe .Net features aren't enabled in a fresh install of win2008, it has to be enabled. Run the following:

servermanagercmd -i NET-Framework-Core

To enable .Net framework. Then, run windows update again.

  • We were having a very similar issue, and that command helped in our situation. Thanks. Dec 12 '11 at 20:18

.NET Framework 2.0 and 3.0 are included in Windows Server 2008, you don't need Windows Update to get them; 3.5 should instead be installed, manually or via Windows Update, because it doesn't come with the Windows setup.

Try turning on .NET-related features in Windows...

  • 3
    As a side note, Windows Server 2008 R2 (based on Windows 7) will also include .NET 3.5 SP1.
    – Powerlord
    Sep 28 '09 at 17:45

To add to what Trondh already said:

Rightclick "my computer" -> Manage click on "Features" In the right pane click on "Add Features" Check the .NET Framework 3.5.1 Features

and follow the wizard to install the framework


I don't think Windows Update automatically installs .NET. I would try installing .NET Framework 2.0SP1 going by your error message.

  • The update is indeed optional, but it would be the preferred way to install it unless you know what you are doing. Oct 6 '09 at 16:50

i recently had to deal with the out of office assistant in outlook 2007 not working with exchange 2007 because of this exact issue. microsoft had me uninstall 3.5 then install .net 2.0 sp1 then .net 2.0 sp2 and reinstall .net 3.5. the issue on my end had to deal with the file system.xml.dll not being properly updated during an install. it was out of sync with what .net 3.5 was expecting and caused the error.


it's old but none of the steps here or anywhere else worked for me. in the end my gut told me to disable anti-virus software. and that did it...now before that I looked at the error message in the application log and it looked like all Server Manager is actually doing is enabling the already installed 3.5 update which AV was probably blocking access to. so don't waste your time and disable anti-virus first.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.