2

I have enabled the iis components for the first time on this machine, from control panel->add software->windows components, and rebooted.

When I attempt to start the "Default Web Site" (which shows as 'Default Web Site (Stopped)' ) from inetmgr nothing happens.. no errors, nothing in the event log. Regmon and Filemon show no obvious errors.

I've confirmed that nothing is running on port 80 and have tried changing the local port (8080, 8081 etc.,) with no effect.

Further info --

I have removed the install, rebooted, added it back in, rebooted ... still not working.

I have visual studio 2008, SQLServer 2008 installed.

1
  • What is the status beside Default Web Site (stopped) in IIS MMC. Apr 8, 2010 at 19:14

2 Answers 2

0

Is there another service listening on port 80? You can find out by running netstat from a command prompt.

1
  • as i say.. i checked that nothing is running on port 80
    – headsling
    Sep 28, 2009 at 22:35
0

Does the site show as started in IIS Manager or the site just doesn't load? Did IIS ever work on that box? What other applications do you have installed on that server?

Make sure to check both System and Application log in Event Viewer and I would suggest trying Process Monitor (www.sysinternals.com) to see if there are any file or registry failures. Search for 'denied' after getting a capture. To get a capture, turn on Process monitor then do an iisreset and try starting the site. That should repro and capture any failures.

3
  • checked regmon and file mon ... no clear errors when iisrestart'ing i.e. no denied, but NOT FOUNDS are there.. not clear which of these would be an issue as they are common place in reg access. This is the first time i'm turning on iis on this machine and inetmgr shows the site as 'Default Web Site (Stopped)' . will update the question with details to your other question. cheers
    – headsling
    Sep 29, 2009 at 10:54
  • 1
    Tis an odd one. It really seems like something else is fighting with port 80 although I know that you've said that you've tried that. Just for kicks, try starting it on another port (i.e. 81), and make sure there isn't a SSL binding yet. It should just have 1 simple binding. (mind you, if there was a port conflict, it should give you an obvious warning about that). The 'Not Founds' are likely ok. There are often lots of those. Sep 29, 2009 at 13:58
  • tried changing the local port with no effect..
    – headsling
    Sep 29, 2009 at 18:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .