3

I'm trying to set up encrypted samba access. In order to achieve that I've added 2 lines to [global] scope in smb.conf:

server signing = mandatory
smb encrypt = mandatory

But unfortunately I can't mount samba shares now anywhere. I've tried with Dolphin under KDE and using mount -t cifs, even tried smbclient command line. I'm getting following errors:

dolphin:

Unknown error condition in stat: Software caused connection abort

mount:

mount error(13): Permission denied

smbclient:

Error returning browse list: NT_STATUS_CONNECTION_DISCONNECTED

how to properly enforce encryption and mount it on linux machine? Windows would be nice as well but I've read that this encryption method is not supported there yet.

I have samba 4.1 on client and 3.6 on server (OpenSUSE / Debian) but tried also looped connection on SUSE 4.1 <> 4.1 with the same result.

1

If I am not mistaken, mount.cifs does not support the encryption feature of Samba (yet!?).

The -e option of smbclient should work, though.

  • I can verify that smbclient (using smbclient Version 4.5.6) works with transport-encrypted partitions. – sweisgerber.dev Mar 30 '17 at 12:11
1

mount.cifs supports SMB3 encryption since version 4.8.0-54.57 of Linux kernel.

So upgrade to the latest Linux kernel and voila!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.