0

So I just put up a LACP between two Cisco catalyst switches.

Snippets of configuration are as following:

[3550 switch - port 22 and 23 are connected to 2950 and 24 is to router]

interface Port-channel1
 switchport access vlan 50
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/22
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode passive
 spanning-tree portfast
!
interface FastEthernet0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 channel-group 1 mode passive
 spanning-tree portfast
!
interface FastEthernet0/24
 switchport access vlan 50
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport voice vlan 10
 spanning-tree portfast
!
interface GigabitEthernet0/1
 switchport mode dynamic desirable
!
interface GigabitEthernet0/2
 switchport mode dynamic desirable
!
interface Vlan1
 no ip address
!
interface Vlan50
 ip address 10.10.10.12 255.255.255.0
!
ip default-gateway 10.10.10.5

[2950 switch - port 23 and 24 are connected to 3550]

interface Port-channel1
 switchport access vlan 50
 switchport mode trunk
 flowcontrol send off
!
interface FastEthernet0/23
 switchport access vlan 50
 switchport mode trunk
 channel-group 1 mode active
 spanning-tree portfast
!
interface FastEthernet0/24
 switchport mode trunk
 channel-group 1 mode active
 spanning-tree portfast
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan50
 ip address 10.10.10.6 255.255.255.0
 no ip route-cache
!
ip default-gateway 10.10.10.5

Now I did some basic "show inter trunk" and "show cdp neighbor," etc to verify. But is there a better/sure way to make sure those two links are aggregated and enhancing bandwidth between the two switches? I wonder if that "flowcontrol" will bother things?

Thanks.

  • You have a "switchport access vlan 50" on the port-channel interface, but it's configured as a trunk. Perhaps you were looking for "switchport trunk native vlan 50"? It's important that the trunk native vlan are identical on both ends. – pauska Jun 4 '15 at 6:56
1

show etherchannel [channel-group] detail

show interfaces port-channel [channel-group]

show lacp [channel-group] counters internal neighbor

0

show etherchannel summary lists all of the channels and their associated interfaces

show int po## as mentioned above shows statistics for the port-channel interface, but also lists the physical member interfaces

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.