3

We have an automatic proxy server configuration setup, and I can use a web browser but ping/curl are failing; it looks like a DNS resolution problem.

When I do:

URLGRABBER_DEBUG=1 yum check-update

Everything seems peach until this:

NSS error -8172 (SEC_ERROR_UNTRUSTED_ISSUER) Peer's certificate issuer has been marked as not trusted by the user.

I have tried a few things, but I'm no network Jedi; could someone with a better understanding of the Force help me out, here?

Thanks!

  • 1
    You may be under a MITM attack. What "few things" have you tried? What are the configs and tracing results? – Deer Hunter May 26 '15 at 4:00
  • I think my corporate proxy looks like a MITM attack because they are doing something funny with their certs (either incorrectly, or in the process of monitoring all traffic). I've tried adding Google's nameserver's to my resolve.conf, I use "proxy=..." and pick one of the IP addresses rather than use automatic proxy configuration, I've made a few other changes (with increasingly less understanding of network 'stuff'). – trayres May 26 '15 at 5:08
  • The automatic proxy server configuration setup may be "blocking". Have you asked your "keepers of the network" to enable your access? – rickhg12hs May 27 '15 at 13:53
  • Yes, I already have network access over port 80; My browser works just fine. There's some other cert problem. – trayres May 30 '15 at 5:03
0

Chances are pretty good that your corporate IT folks are signing their own certs (and intercepting all traffic, etc.). If you don't think they are evil, you could try adding ...

sslverify=0

in

/etc/yum.conf

and then hopefully yum will "just work", though less securely.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.