0

Downloaded the - jre-8u45-linux-i586.rpm

Opened console - su

  • mkdir /usr/bin/java [No java was installed before]
  • cd /usr/bin/java
  • rpm -ivh jre-8u45-linux-i586.rpm [Tried installing]
    error: open of jre-8u45-linux-i586.rpm failed:no such file or directory

Clearly I have it on the desktop

Opened File System - /usr/bin/java, which I created

Tried moving the jre-8u45-linux-i586.rpm file from desktop to /usr/bin/java, but I get:

Error moving file: Permission Denied

So I have two problems

  • Installing the rpm package
  • Getting access to my own system

Sorry, I'm really new to Linux, and tried googling the problems, the solutions there are really complicated, I thought I don't have a complicated situation here.

  • Why are you trying to install a 32-bit Java? – Michael Hampton May 26 '15 at 19:28
  • I must use it. There is no other way, the program i need to open in VPS is 32bit only. If 64bit java is installed, the .jar does not respond. – Rea Lop May 26 '15 at 19:29
1

First, you don't need to create /usr/bin/Java or any directory. Secondly, your invocation of rpm is pointing to the rom in the current directory, which is the directory you made, you would need to point to it as ~/Downloads/java....rpm. Finally, you should use yum to install rpms because it will help pull in any needed dependencies. yum install ~/Downloads/java...rpm. If you don't do this as root, you should make it like sudo yum ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.