2

Problem:

  • Windows 2008 R2 or Windows 2012 servers have no network access after a reboot
  • Not all VMs affected, but multiple VMs and mulitiple hosts.
  • Windows Network configuration shows the correct info
  • Ipconfig shows a 169.254.x.x IP address
  • Disabling and re-enabling the guest NIC fixes the issue. Also, a VM disconnect/connect fixes the issue.

Things I have tried:

  • Switch vNIC from E1000 and E1000e to VMXNET3 (per VMware support). This appeared to work for a while, but the problem continues.
  • Updated VMware tools (appeared to help at first)
  • Updated hypervisor (appeared to help at first)
  • Today I opened a new VMware support ticket

A similar question on serverFault proposed a solution of turing off power management in device manager. I will see if this helps, but I doubt this will help. I do not think the OS is trying to save power during the bootup process.

3
  • When the above happens, are you able to ping the autoconfig IP address from another host outside of the ESXi server? The other host will need to be on the same L2 broadcast domain as well as being configured with an IP address in the same subnet as the 168.254.0.0 that the server has. – EEAA May 26 '15 at 22:51
  • I have not tried to ping the autoconfig address. – Paul May 27 '15 at 0:05
  • What version of ESXi and vSphere are you using? – Citizen Jun 22 '16 at 7:06
2

I cannot confirm yet, but I believe I found a solution. I say this because the symptoms are very very close to what I am seeing.

VMware KB: False duplicate IP address detected on Microsoft Windows Vista and later virtual machines on ESX/ESXi when using Cisco devices on the environment http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1028373

Duplicate IP Address 0.0.0.0 Error Message Troubleshoot - Cisco http://www.cisco.com/c/en/us/support/docs/ios-nx-os-software/8021x/116529-problemsolution-product-00.html

Note: I am trying this combination of Cisco commands

ip device tracking probe delay 20 ip device tracking probe interval 45

one of those two command may have took down my network for a minute or two. :-/

You might want to do this during a maintenance window!!!

1

Try to move him into a different VLAN on another cluster to see if the issue persists. I have found that the VLAN IDs can cause this problem, especially in a VDS Configuration.

See Here:

enter image description here

Try changing the port ID.

1

This happened quite a bit with some of our Windows VMs (2008 R2 and 2012). However, the problem only shows itself after a number of reboots - the actual number seems rather nondeterministic (betwwen 2 and 20).

After setting the ArpRetryCount to 0 as recommended in KB article 1028373 the problem did not occur anymore.

To work around this issue, turn off gratuitous ARP in the guest operating system. To turn off gratuitous ARP in the guest operating system:

  1. Shut down the guest operating system and power off the virtual machine.

  2. Change the virtual machine to a network vSwitch with no uplink. You can create one for this procedure.

  3. Power on the virtual machine and log in.

  4. Open the Registry editor.
    • In Windows XP to Windows Server 2003 - Click Start > Run, type regedit, and click OK.
    • In Windows 7 and Current - Click Start, type regedit, and click OK.
  5. Locate this registry key:
    • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
  6. Click Edit > New, and click DWORD Value.
  7. Type ArpRetryCount.
  8. Right-click the ArpRetryCount registry entry and click Modify.
  9. In the Value box, type 0 and click OK.
  10. Exit the Registry Editor.
  11. Shut down the guest operating system and power off the virtual machine.
  12. Change the virtual machine back to a network vSwitch with the uplink.
  13. Power on the virtual machine.

This has now become standard procedure for all our Windows server VMs.

1
  • It is good to include a small portion of the web you are providing in your reply. You avoid problems if the web is no longer available, and is more straighforward to check the answer. – alphamikevictor Jun 10 '15 at 14:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.