0

We have HP Proliant ML370 G6 server with 4 gigabit ports on it. 3 ports work well, but 1 (LAN1) cuts TCP Down traffic. TCP Up and UDP is ok. Here is the speed test result.
Here is the windows monitor on the server.

The server is connected to Cisco 2960g switch with all 4 ports. 3 of them used for Hyper-V and this one is for the server itself.

The speed test is between this server and the other in the same subnet, connected to the same switch.

The result is the same when I test speed between this server and other computers in the LAN.

I want to fix it, but don't know how. I don't know where is the problem also. Is it on the network interface or is it on the switch? How to diagnose it? Why TCP-download traffic only? Maybe someone ever faced the same problem?

Here is the qos settings on cisco 2960 switch:

mls qos srr-queue input threshold 1 8 16  
mls qos srr-queue input threshold 2 34 66  
mls qos srr-queue input cos-map queue 1 threshold 2 1  
mls qos srr-queue input cos-map queue 1 threshold 3 0  
mls qos srr-queue input cos-map queue 2 threshold 1 2  
mls qos srr-queue input cos-map queue 2 threshold 2 4 6 7  
mls qos srr-queue input cos-map queue 2 threshold 3 3 5  
mls qos srr-queue input dscp-map queue 1 threshold 2 9 10 11 12 13 14 15  
mls qos srr-queue input dscp-map queue 1 threshold 3 0 1 2 3 4 5 6 7  
mls qos srr-queue input dscp-map queue 1 threshold 3 32  
mls qos srr-queue input dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23  
mls qos srr-queue input dscp-map queue 2 threshold 2 33 34 35 36 37 38 39 48  
mls qos srr-queue input dscp-map queue 2 threshold 2 49 50 51 52 53 54 55 56  
mls qos srr-queue input dscp-map queue 2 threshold 2 57 58 59 60 61 62 63  
mls qos srr-queue input dscp-map queue 2 threshold 3 24 25 26 27 28 29 30 31  
mls qos srr-queue input dscp-map queue 2 threshold 3 40 41 42 43 44 45 46 47 

The server is connected to the gi0/1-gi0/4

interface GigabitEthernet0/1
 description -= Host - LAN 1 =-
 switchport mode access
!
interface GigabitEthernet0/2
 description -= Host - LAN 2 =-
 switchport mode access
!
...
interface GigabitEthernet0/7
description -= Cisco Router 881-W - Fa0 =-
switchport mode trunk
auto qos voip trust
!
...
interface Vlan1
description -= Vlan 1 =-
ip address 10.10.10.2 255.255.255.0
no ip route-cache
!
...

show vlans

1    default                          active    Gi0/1, Gi0/2, Gi0/3, Gi0/4
                                                Gi0/5, Gi0/6, Gi0/8
2    Mgmnt                            active
3    Voice                            active    Gi0/8
...
6
  • What is your question? May 27, 2015 at 8:13
  • I want to fix it, but don't know how. I don't know where is the problem also. Is it on the network interface or is it on the switch? How to diagnose it? Maybe someone ever faced the same problem? May 27, 2015 at 8:15
  • What other data is that port carrying? It's poor overall. What does that QoS traffic setting do?
    – hookenz
    May 27, 2015 at 8:39
  • You need to swap the cables and IP's between this suspect port and any of the others to figure out if it is the port that's the problem or the downstream link.
    – Chopper3
    May 27, 2015 at 8:48
  • Here is the screen of windows monitor (sorry for language): rghost.ru/private/7yFNWnWsF/0ccb3be536cd99c3ff3d6a0170ad509f/… As we can see, there is low traffic load on the interface about 19 kbps. May 27, 2015 at 8:54

1 Answer 1

0

first of all I would recommend to check the cabling and try to use another cable. You should also check the packet errors on the link on the switch side. TCP use the window for sending the data. If there is any error on the link and the speed is not as suspected and there are some packet drops, TCP slows down the speed of sending the packets automatically.

For checking the errors on interface use standard show int GigabitEthernet0/4 command and check the last section with >>> lines ...

 0 packets input, 0 bytes, 0 no buffer
 Received 0 broadcasts (0 multicasts)
 0 runts, 0 giants, 0 throttles
 >>> 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
 0 watchdog, 0 multicast, 0 pause input
 0 input packets with dribble condition detected
 0 packets output, 0 bytes, 0 underruns
 >>> 0 output errors, 0 collisions, 1 interface resets
 0 babbles, 0 late collision, 0 deferred
 0 lost carrier, 0 no carrier, 0 PAUSE output
 0 output buffer failures, 0 output buffers swapped out

lybor

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.