0

I have a Django 1.7 website configured on IIS 8 platform. The staticfiles are kept in a folder generated after running collectstatic command. As mentioned in the tutorials I have made that folder a virtual directory and deleted the django handler from it.

Everything worked well till the point I added a new file in my static directory and ran collectstatic again. Now my static files give a 404 error saying The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

I don't understand why would this happen as I have not changed any of my prior settings.

0

My url for the staticfiles was broken. I add the code below to my urlpatterns.

url(r'^site_media/static/(?P<path>.*)$', 'django.views.static.serve', {
    'document_root': settings.STATIC_ROOT,
})

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.