I am running Debian 7.8 (wheezy) which is installed on a Windows Hyper-V server (not managed by me). However, the server frequently goes into 'read only' mode and I am not sure why. I have looked in dmesg but, to be honest, I do not know what I am looking at or for. I ran fsck after reboot and there were errors e.g.

fsck died with exit status 4
...
Inotes that were part of a corrupted orphan linked list found. Fix
Inode <number> was part of the orphaned inode list. FIXED
...
Block bitmap differences: ....
Free blocks count wrong for group ...

After the reboot everything is ok.

Here is the output from dmesg after I ran fsck:

    [    5.951324] scsi scan: INQUIRY result too short (5), using 36
    [    5.951735] scsi scan: INQUIRY result too short (5), using 36
    [    5.951933] input: Microsoft Vmbus HID-compliant Mouse as /devices/virtual/input/input1
    [    5.952228] hid 0006:045E:0621.0001: input: <UNKNOWN> HID v0.01 Mouse [Microsoft Vmbus HID-compliant Mouse] on
    [    5.953338] hv_netvsc: hv_netvsc channel opened successfully
    [    6.057589] hv_netvsc vmbus_0_14: Device MAC 00:15:5d:00:fa:01 link state up
    [   10.954244] sd 2:0:0:0: [sda] 1006632960 512-byte logical blocks: (515 GB/480 GiB)
    [   10.954325] sd 2:0:0:0: [sda] Write Protect is off
    [   10.954330] sd 2:0:0:0: [sda] Mode Sense: 0f 00 00 00
    [   10.954539] sd 2:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
    [   10.956129]  sda: sda1 sda2 < sda5 >
    [   10.957221] sd 2:0:0:0: [sda] Attached SCSI disk
    [   11.311017] PM: Starting manual resume from disk
    [   11.311022] PM: Hibernation image partition 8:5 present
    [   11.311024] PM: Looking for hibernation image.
    [   11.311494] PM: Image not found (code -22)
    [   11.311497] PM: Hibernation image not present or could not be loaded.
    [   11.404052] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
    [   12.562030] udevd[348]: starting version 175
    [   12.959687] input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input2
    [   12.959696] ACPI: Power Button [PWRF]
    [   12.977694] hv_utils: Registering HyperV Utility Driver
    [   12.977698] hv_vmbus: registering driver hv_util
    [   13.080426] piix4_smbus 0000:00:07.3: SMBus base address uninitialized - upgrade BIOS or use force_addr=0xaddr
    [   13.083881] input: PC Speaker as /devices/platform/pcspkr/input/input3
    [   13.170434] alg: No test for __gcm-aes-aesni (__driver-gcm-aes-aesni)
    [   13.507475] trackpoint.c: failed to get extended button data
    [   16.708356] IBM TrackPoint firmware: 0x01, buttons: 0/0
    [   16.710497] input: TPPS/2 IBM TrackPoint as /devices/platform/i8042/serio1/input/input4
    [   19.075083] Adding 16773116k swap on /dev/sda5.  Priority:-1 extents:1 across:16773116k
    [   19.099050] EXT4-fs (sda1): re-mounted. Opts: (null)
    [   19.335774] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
    [   19.412413] loop: module loaded
    [   20.685798] RPC: Registered named UNIX socket transport module.
    [   20.685802] RPC: Registered udp transport module.
    [   20.685811] RPC: Registered tcp transport module.
    [   20.685813] RPC: Registered tcp NFSv4.1 backchannel transport module.
    [   20.721997] FS-Cache: Loaded
    [   20.754261] FS-Cache: Netfs 'nfs' registered for caching
    [   20.763161] Installing knfsd (copyright (C) 1996 okir@monad.swb.de).
    [   23.477630] Bluetooth: Core ver 2.16
    [   23.477651] NET: Registered protocol family 31
    [   23.477653] Bluetooth: HCI device and connection manager initialized
    [   23.477656] Bluetooth: HCI socket layer initialized
    [   23.477658] Bluetooth: L2CAP socket layer initialized
    [   23.477849] Bluetooth: SCO socket layer initialized
    [   23.488920] Bluetooth: RFCOMM TTY layer initialized
    [   23.488926] Bluetooth: RFCOMM socket layer initialized
    [   23.488928] Bluetooth: RFCOMM ver 1.11
    [   23.496819] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
    [   23.496822] Bluetooth: BNEP filters: protocol multicast
    [   28.716625] postgres (3298): /proc/3298/oom_adj is deprecated, please use /proc/3298/oom_score_adj instead.
    [   41.096759] mtrr: type mismatch for f8000000,400000 old: write-back new: write-combining
    [   56.353460] hv_storvsc vmbus_0_1: cmd 0x85 scsi status 0x2 srb status 0x86
    [   56.353465] hv_storvsc vmbus_0_1: stor pkt ffff8801fbb0e2c0 autosense data valid - len 18
    [   56.353468] storvsc: Sense Key : Illegal Request [current]
    [   56.353472] storvsc: Add. Sense: Invalid command operation code

Any pointers to log files that I could look in would be greatly appreciated.

up vote 1 down vote accepted

This might be occurring due to backups, please see https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1445195 for the related issue posted on the Ubuntu kernel.

  • Thank you, looks like the same issue. How would I go about applying the update baring in mind I am using debian and not ubuntu? – Dudedolf Jun 1 '15 at 12:53

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.