4

I have a jenkins (initially 1.596.2, later upgraded to .3) master on Ubuntu, with some jobs.

Last week i started seeing jobs being put on queue (pending—Waiting for next available executor). I checked the job config (Restrict where this project can be run) and it says Slaves in label: 1. The master workers all report idle. I upgraded to 1.596.3, restarted the node, but after a couple of hours of working (around 10-12) it starts to put jobs on queue although workers are idle.

It doesn't have any slaves, there are plenty of resources (node is a VM with 8 GB of RAM and 500 GB disk) and there are no errors in dmesg or logs.

What can i do to unblock it?

Thanks, Ed

0

I ran into a similar problem where I have "Batch Tasks" (Batch Tasks plugin) in the queue that don't kick off and block the execution queue. By removing the tasks from the queue, it resumes execution for regular jobs.

It may or may not be your issue.

0

I had this issue as well with Jenkins 1.639
I restarted Jenkins the first time and still had the issue
I had 2 executors in the master node, added 3 more for a total of 5
Restarted Jenkins again and this time it worked!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.