0

I'm trying to use QEmu for Windows to convert a virtual disk image to a physical SSD. But I'm not sure about the syntax for the output_filename parameter. Here's what I tried:

qemu-img convert -p "D:\Virtual Machines\LinuxMint\LinuxMint-System.vdi" -O raw \\.\PHYSICALDRIVE5

But I get this error:

qemu-img: Could not open '-O': Could not open '-O': Invalid argument

Note that I do not have any partitions on the output drive - it's a bare drive.

Also, I only want to do this if I'll see a decent performance gain - so if it doesn't make a difference, then I won't bother.

0

I am not familiar with Windows qemu, on linux , the command line should be

qemu-img convert -O raw ${the_virtual_disk_image}  /dev/${the_ssd}

SO, you may have a try like

qemu-img convert -p -O raw "D:\Virtual Machines\LinuxMint\LinuxMint-System.vdi"  \\.\PHYSICALDRIVE5
  • Thanks, but notice that your suggestion is exactly what I have in the OP. :) – Josh M. Jun 5 '15 at 2:49
  • 1
    I mean , you should put all options (ie. ' -O raw') before the input&output files. – grizzlybears Jun 8 '15 at 2:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.