0

I am connected to a reliance wifi connection obtained a 192.168.0.101 ip. 192.168.0.1 as primary dns. I configured dns bind to give name to my server process. To test that locally i changed the dhclient.conf "prepend domain-name-servers 127.0.0.1;" so that my resolv.conf changed to namserver 127.0.0.1. and my primary dns changed to 127.0.0.1

ashokkrishna@krishna:~$ nslookup group.hom
Server:     127.0.0.1
Address:    127.0.0.1#53

** server can't find group.hom: SERVFAIL

and the config file

ashokkrishna@krishna:/etc/bind$ cat named.conf.local
# Our domain zone
zone "group.hom" {
   type master;
   file "/etc/bind/zones/group.hom.db";
};

# For reverse DNS 
zone "0.168.192.in-addr.arpa" {
   type master;
   file "/etc/bind/zones/rev.0.168.192.in-addr.arpa";
};

the forward zone file.

ashokkrishna@krishna:/etc/bind/zones$ cat group.hom.db
;
; BIND data file for local loopback interface
;
$TTL    604800
@   IN  SOA i.group.hom. root.group.hom. (
                  2     ; Serial
             604800     ; Refresh
              86400     ; Retry
            2419200     ; Expire
             604800 )   ; Negative Cache TTL
;
@   IN  NS  group.hom.
@   IN  A   192.168.0.101
www     IN  A       192.168.0.101

reverse zone

ashokkrishna@krishna:/etc/bind/zones$ cat rev.0.168.192.in-addr.arpa
;
; BIND data file for local loopback interface
;
$TTL    604800
@   IN  SOA i.group.hom. root.group.hom. (
                  2     ; Serial
             604800     ; Refresh
              86400     ; Retry
            2419200     ; Expire
             604800 )   ; Negative Cache TTL
;
@   IN  NS  group.hom.
101.0.168   IN  PTR group.hom.

/etc/hosts

ashokkrishna@krishna:/etc/bind/zones$ cat /etc/hosts
127.0.0.1   localhost
127.0.0.1      krishna
192.168.0.101       i.group.hom    i

named.conf.options

dnssec-validation auto;

    auth-nxdomain no;    # conform to RFC1035
    listen-on-v6 { any; };
};

why i am getting this error? bind successfully running but it is not giving the name to my system. its not connecting why.?

new zone database:

;
; BIND data file for local loopback interface
;
$TTL    604800
@   IN  SOA ib.group.hom. root.group.hom. (
                  2     ; Serial
             604800     ; Refresh
              86400     ; Retry
            2419200     ; Expire
             604800 )   ; Negative Cache TTL
;
@   IN  NS  group.hom.
group.hom.    IN    A    192.168.0.101
@   IN  A   192.168.0.101
www     IN  A       192.168.0.101
0

Try to add to your zone (group.hom.db) this:

group.hom.    IN    A    192.168.0.1

Because you only have an entry for www.group.hom

| improve this answer | |
  • is it 192.168.0.1 ? – ashok May 30 '15 at 7:34
  • ashokkrishna@krishna:~$ sudo named-checkzone group.hom.db /etc/bind/zones/group.hom.db /etc/bind/zones/group.hom.db:13: ignoring out-of-zone data (group.hom) – ashok May 30 '15 at 7:45
  • after adding group.hom. IN A 192.168.0.1 – ashok May 30 '15 at 7:45
  • Did you restart named and tried to query again group.hom ? – alphamikevictor May 30 '15 at 8:07
  • after adding group.hom IN A 192.168.0.101 – ashok May 30 '15 at 9:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.