0

I am trying to install mailman on my local machine. I am using debian 8. I installed mailman simply using apt-get install mailman. Then i copied mailman.conf file to /etc/apache2/sites-available/mailman.conf.

Now when i am trying to open this link in my browser localhost/mailman/listinfo then instead of opening the page it is downloading that script which should not be happening.

This is mailman.conf file.

ScriptAlias /cgi-bin/mailman/ /usr/lib/cgi-bin/mailman/
# And the public archives:
Alias /pipermail/ /var/lib/mailman/archives/public/
# Logos:
Alias /images/mailman/ /usr/share/images/mailman/

# Use this if you don't want the "cgi-bin" component in your URL:
# In case you want to access mailman through a shorter URL you should enable
# this:
ScriptAlias /mailman/ /usr/lib/cgi-bin/mailman/
# In this case you need to set the DEFAULT_URL_PATTERN in
# /etc/mailman/mm_cfg.py to http://%s/mailman/ for the cookie
# authentication code to work.  Note that you need to change the base
# URL for all the already-created lists as well.

<Directory /usr/lib/cgi-bin/mailman/>
  AllowOverride None
  Options ExecCGI
  AddHandler cgi-script .cgi
#     Order allow,deny
#    Allow from all
  Require all granted
</Directory>
<Directory /var/lib/mailman/archives/public/>
  Options FollowSymlinks
  AllowOverride None
#    Order allow,deny
#    Allow from all
  Require all granted
</Directory>
<Directory /usr/share/images/mailman/>
  AllowOverride None
#    Order allow,deny
#    Allow from all
  Require all granted
</Directory>

This is what i am getting now on doing tail -f *.log in /var/log/apache2. In my browser i put this localhost/cgi-bin/mailman/confirm

::1 - - [01/Jun/2015:14:43:36 +0530] "GET /cgi-bin/mailman/confirm HTTP/1.1" 200 10463 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 Iceweasel/31.6.0"

I am confused as what to do.

  • This indicates that the script handler is not active. Check the apache config if it matches your setup. Also try howtoforge.com/… – user219962 Jun 1 '15 at 8:54
  • @EliDevender what is apache configbifbit ? Please care to explain. – shivams Jun 1 '15 at 8:57
  • "Config if it" sorry... – user219962 Jun 1 '15 at 8:58
  • @EliDevender I have edited my question with mailman.conf file. I am not able to find anything out of ordinary in it. – shivams Jun 1 '15 at 9:07
  • Seems to be ok. Any error in your apache log? – user219962 Jun 1 '15 at 9:08
1

In my own fresh Apache2 installation on Debian 8, I found to my surprise that the CGI Apache module was not enabled by default. This may the case in your situation as well.

Try:

sudo a2enmod cgi
sudo service apache2 restart

...and see if that makes things better. (It did for me.)

0

In Debian the configuration in sites-available is not automatically applied. I believe you'll need to do something like

sudo a2ensite mailmain
sudo systemctl restart apache2

and see if that allows the CGI to be properly interpreted.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.