22

One of our remote Windows 7 Professional users just reported that he received an Upgrade Reservation Offer for Windows 10. It appears the Get Windows 10 "App" running in his system tray is legit. So far, this is only seems to be hitting devices that are not domain-joined.

Short of uninstalling/hiding the Windows Update that enabled the upgrade, is there any way to disable the Upgrade App (and of course the upgrade itself)?

  • That doesn't seem odd at all. windowsitpro.com/windows-10/… - "any Pro version of Windows 7 and Windows 8 (which most small and medium-sized businesses use) will get the upgrade to Windows 10 for free over Windows Update, just like those designated to quote/unquote consumers.". I was also wondering today if there would be a way to block it. – TessellatingHeckler Jun 1 '15 at 21:02
  • @TessellatingHeckler: You're right. Edited the question to remove inaccurate information. – poke Jun 1 '15 at 22:21
  • Has anyone seen this come through on an Enterprise version of Windows 7/8/8.1? Or does it only apply to Pro (and lower), as it should? – blaughw Jun 1 '15 at 22:55
  • 1
    I have consolidated the two most upvoted answers into this single command: reg add HKLM\SOFTWARE\Policies\Microsoft\Windows\Gwx /v "DisableGwx" /t REG_DWORD /d 0x1 & reg add HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate /v "DisableOSUpgrade" /t REG_DWORD /d 0x1 (The first one hides the update notification, while the second one blocks the OS upgrade) To verify, replace 'reg add' with 'reg query' and remove all parameters – wandersick May 27 '16 at 14:59
19

According to this article you can add the following registry entry to disable Get Windows 10:

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Gwx]
"DisableGwx"=dword:00000001

Try HLM\Software\WOW6432Node\RegisteredApplications\GWX and rename it.

  • 2
    +1: Applied the key and killed gwx.exe. Didn't come back after a reboot. – poke Jun 2 '15 at 14:04
8

To properly disable the Windows 10 upgrade as recommended by microsoft I would advise reading the following article:

Ref: https://support.microsoft.com/en-us/kb/3080351

Computer Configuration

To block the upgrade by using Computer Configuration, follow these steps

Click Computer Configuration.

Click Policies.

Click Administrative Templates.

Click Windows Components.

Click Windows Update.

Double-click Turn off the upgrade to the latest version of Windows through Windows Update.

Click Enable.

Policy path

Computer Configuration / Administrative Templates / Windows Components / Windows Update Policy

Setting: Turn off the upgrade to the latest version of Windows through Windows Update

Windows registry

Important Follow the steps in this section carefully. Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur.

To suppress this offer through the registry, specify the following registry value:

Subkey: HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate DWORD value: DisableOSUpgrade = 1

  • 2
    You missed a step. This Group Policy won't exist on a Windows 7 machine unless it has the Windows Update Client for Windows 7 and Windows Server 2008 R2: July 2015 – austinian Aug 25 '15 at 20:51
  • @austinian I think it is the same case for the DC. I looked in the GPO for the domain on my Server 2012 and can't find these GPO keys. – bgmCoder Mar 14 '16 at 14:09
  • So I had to first install Windows8.1-KB3065988-v2-x64.msu on the domain controller before I could have the option in GPO. And I also discovered that I could not install the KB on the secondary domain controller - only on the primary. – bgmCoder Mar 14 '16 at 15:44
  • If you edit the domain GPO from a Windows 7 machine using RSAT with the KB installed, then you can do so without installing the KB on the DC. – austinian Mar 14 '16 at 16:09
  • It wasn't obvious to me, so I'll save others some time. You should first uninstall KB3035583 (the GWX update). Then do these things listed (I already had the Group Policy (start menu->search "policy"->edit group policy) and set it to "Enable"). I also added HKLM\Software\Policies\Microsoft\Windows\Gwx DWORD value: DisableGwx = 1 as stated in the MS KB article. Restarted PC and GXW was gone, Windows Update re-installs KB3035583. Restart again and this time GWX stays disabled (but shows up in system32 folder). Good enough. First time I did this I didn't uninstall KB3035583 and it stayed active. – HodlDwon Apr 24 '16 at 12:18
5

It's this guy: KB3035583. You may want to script a wusa.exe /uninstall for this one if it's already in the wild. This has been big news today, as Microsoft put this out last Patch Tuesday, and somehow forgot to mention the time-delay sales pitch set for June 1st.

Normally you would block this update in WSUS/SCCM. Of course, in this case you couldn't have known what to block. I certainly didn't get a notification from my MS team in my Advance Notice emails.

The folks over at SuperUser are ALL over this today as well:

https://superuser.com/questions/922068/how-to-disable-the-get-windows-10-icon-shown-in-the-notification-area-tray

  • I tried this on a test system. The update uninstalled just fine but re-installed overnight. The icon is back in the system tray. Any thoughts on how to block this without using WSUS/SCCM? – poke Jun 2 '15 at 12:12
  • @poke: Just uninstall it once again, then go to Control Panel > System and Security > Windows Update > Select updates to install - You will see this uninstalled update available in the list > Right click on it and select "Hide update" - this will do the trick. Surprisingly I'm unable to find CLI tool or PowerShell cmdlet to do this without wading through GUI. – Mikhail Jun 3 '15 at 8:24
  • @Mikhail: It would be nice if they had CLI option. GUI the option is useful for situations involving exactly 1 or maybe 2 computers, but absolutely no more :-) – poke Jun 3 '15 at 13:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.