0

I haven't done a Cisco configuration from scratch before but I'm trying to get familiar. I've only made adjustments previously.

That said, I'm trying to diagnose a problem with using my Cisco 2801 with an HWIC-1ADSL for a PPPoE connection.

PPPoE authentication goes through fine, and I even get an IP for the external interface, but the default route provided by my ISP appears to be provided, but is not installed.

Here's some debug output:

*May 29 05:06:04.950: Vi1 PPP DISC: Authentication configuration changed
*May 29 05:06:04.950: PPP: NET STOP send to AAA.
*May 29 05:06:04.950: Vi1 IPCP: Event[DOWN] State[Open to Starting]
*May 29 05:06:04.950: Vi1 IPCP: Event[CLOSE] State[Starting to Initial]
*May 29 05:06:04.954: Vi1 LCP: Event[DOWN] State[Open to Starting]
*May 29 05:06:04.954: Vi1 PPP: Send Message[Renegotiate]
*May 29 05:06:04.954: Vi1 PPP: Phase is DOWN
*May 29 05:06:04.954: Di0 Deleted neighbor route from AVL tree: topoid 0, address XX.YY.225.104
*May 29 05:06:04.954: Di0 IPCP: Remove route to XX.YY.225.104
*May 29 05:06:04.958: Vi1 PPP: Received Renegotiate from PPP
*May 29 05:06:04.958: Vi1 PPP: ppp_sip_switching_cleanup
*May 29 05:06:04.958: Vi1 PPP: Change SIP state from Init to Down
*May 29 05:06:04.958: Vi1 PPP: Change SIP state from Down to SSS Setup
*May 29 05:06:04.958: Vi1 PPP: old[Down] event[CstateUp] state[SSS Setup]
*May 29 05:06:04.958: Vi1 PPP: old[Up] event[PPPReneg] state[SSS Setup]
*May 29 05:06:04.958: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to down
*May 29 05:06:04.962: Vi1 PPP SIP segment: Provisioned
*May 29 05:06:04.962: Vi1 PPP SIP segment:     if_number     9
*May 29 05:06:04.962: Vi1 PPP SIP segment:     sub_if_number 9
*May 29 05:06:04.962: Vi1 PPP SIP segment:     ppp_vencap    631BD24C
*May 29 05:06:04.962: Vi1 PPP SIP segment:     access id     9F00009B
*May 29 05:06:04.962: Vi1 PPP SIP segment:     switch hdl    0
*May 29 05:06:04.962: Vi1 PPP SIP segment:     sss circuit   0
*May 29 05:06:04.962: Vi1 PPP SIP segment:     lcp magic     62CFF3CF
*May 29 05:06:04.962: Vi1 PPP SIP segment:     local term    1
*May 29 05:06:04.962: Vi1 PPP SIP segment:     lcp up        1
*May 29 05:06:04.962: Vi1 PPP SIP segment:     punt to RP    0
*May 29 05:06:04.962: Vi1 PPP SIP segment:     cond debug    1
*May 29 05:06:04.962: Vi1 PPP SIP segment:     vp_bound      0
*May 29 05:06:04.962: Vi1 PPP SIP segment:     fwded         0
*May 29 05:06:04.962: Vi1 PPP SIP segment: Unbind
*May 29 05:06:04.966: Vi1 PPP: Received SSS-Mgr Need-More-Keys from SSS
*May 29 05:06:04.966: Vi1 PPP: Change SIP state from SSS Setup to Binding
*May 29 05:06:04.966: Vi1 PPP: old[SSS Setup] event[MoreKeys] state[Binding]
*May 29 05:06:04.966: Vi1 PPP: Static Bind peer_type[0]
*May 29 05:06:04.966: Vi1 PPP: Send Message[Static Bind Response]
*May 29 05:06:04.966: Vi1 PPP: Authorization required
*May 29 05:06:04.966: Vi1 PPP: Using dialer call direction
*May 29 05:06:04.966: Vi1 PPP: Treating connection as a callout
*May 29 05:06:04.970: Vi1 PPP: Session handle[4900009E] Session id[155]
*May 29 05:06:04.970: Vi1 LCP: Event[OPEN] State[Initial to Starting]
*May 29 05:06:04.970: Vi1 PPP: No remote authentication for call-out
*May 29 05:06:04.970: Vi1 LCP: O CONFREQ [Starting] id 1 len 10
*May 29 05:06:04.970: Vi1 LCP:    MagicNumber 0x62DD547C (0x050662DD547C)
*May 29 05:06:04.970: Vi1 LCP: Event[UP] State[Starting to REQsent]
*May 29 05:06:04.970: Vi1 PPP: Received Static Bind Response from PPP
*May 29 05:06:04.970: Vi1 PPP: Change SIP state from Binding to Up
*May 29 05:06:04.970: Vi1 PPP: old[Binding] event[PPPBindResp] state[Up]
*May 29 05:06:04.970: Vi1 PPP SIP segment: Unprovision
*May 29 05:06:04.970: Vi1 PPP SIP segment: CLEANUP
*May 29 05:06:05.030: Vi1 LCP: I CONFREQ [REQsent] id 1 len 18
*May 29 05:06:05.034: Vi1 LCP:    MRU 1492 (0x010405D4)
*May 29 05:06:05.034: Vi1 LCP:    AuthProto PAP (0x0304C023)
*May 29 05:06:05.034: Vi1 LCP:    MagicNumber 0x3BAA0A4C (0x05063BAA0A4C)
*May 29 05:06:05.034: Vi1 LCP: O CONFNAK [REQsent] id 1 len 8
*May 29 05:06:05.034: Vi1 LCP:    MRU 1500 (0x010405DC)
*May 29 05:06:05.034: Vi1 LCP: Event[Receive ConfReq-] State[REQsent to REQsent]
*May 29 05:06:05.034: Vi1 LCP: I CONFACK [REQsent] id 1 len 10
*May 29 05:06:05.034: Vi1 LCP:    MagicNumber 0x62DD547C (0x050662DD547C)
*May 29 05:06:05.034: Vi1 LCP: Event[Receive ConfAck] State[REQsent to ACKrcvd]
*May 29 05:06:05.042: Vi1 LCP: I CONFREQ [ACKrcvd] id 2 len 18
*May 29 05:06:05.042: Vi1 LCP:    MRU 1500 (0x010405DC)
*May 29 05:06:05.042: Vi1 LCP:    AuthProto PAP (0x0304C023)
*May 29 05:06:05.042: Vi1 LCP:    MagicNumber 0x3BAA0A4C (0x05063BAA0A4C)
*May 29 05:06:05.042: Vi1 LCP: O CONFACK [ACKrcvd] id 2 len 18
*May 29 05:06:05.042: Vi1 LCP:    MRU 1500 (0x010405DC)
*May 29 05:06:05.042: Vi1 LCP:    AuthProto PAP (0x0304C023)
*May 29 05:06:05.042: Vi1 LCP:    MagicNumber 0x3BAA0A4C (0x05063BAA0A4C)
*May 29 05:06:05.042: Vi1 LCP: Event[Receive ConfReq+] State[ACKrcvd to Open]
*May 29 05:06:05.046: Vi1 PPP: No authorization without authentication
*May 29 05:06:05.046: Vi1 PPP: Phase is AUTHENTICATING, by the peer
*May 29 05:06:05.046: Vi1 PAP: Using hostname from interface PAP
*May 29 05:06:05.046: Vi1 PAP: Using password from interface PAP
*May 29 05:06:05.046: Vi1 PAP: O AUTH-REQ id 1 len 27 from "luser"
*May 29 05:06:05.046: Vi1 LCP: State is Open
*May 29 05:06:05.106: Vi1 PAP: I AUTH-ACK id 1 len 5
*May 29 05:06:05.106: Vi1 PPP SSS: Forwarding request
*May 29 05:06:05.110: Vi1 PPP: Phase is FORWARDING, Attempting Forward
*May 29 05:06:05.110: Vi1 PPP: Queue IPCP code[1] id[1]
*May 29 05:06:05.110: Vi1 PPP: Received SSS-Mgr Connect-Local from SSS
*May 29 05:06:05.110: Vi1 PPP: Phase is ESTABLISHING, Finish LCP
*May 29 05:06:05.114: Vi1 PPP: Phase is UP
*May 29 05:06:05.114: Vi1 IPCP: Protocol configured, start CP. state[Initial]
*May 29 05:06:05.114: Vi1 IPCP: Event[OPEN] State[Initial to Starting]
*May 29 05:06:05.114: Vi1 IPCP: O CONFREQ [Starting] id 1 len 10
*May 29 05:06:05.114: Vi1 IPCP:    Address 0.0.0.0 (0x030600000000)
*May 29 05:06:05.114: Vi1 IPCP: Event[UP] State[Starting to REQsent]
*May 29 05:06:05.114: Vi1 PPP: Process pending ncp packets
*May 29 05:06:05.114: Vi1 IPCP: Redirect packet to Vi1
*May 29 05:06:05.114: Vi1 IPCP: I CONFREQ [REQsent] id 1 len 10
*May 29 05:06:05.114: Vi1 IPCP:    Address XX.YY.225.104 (0x0306D80EE168)
*May 29 05:06:05.114: Vi1 IPCP: O CONFACK [REQsent] id 1 len 10
*May 29 05:06:05.114: Vi1 IPCP:    Address XX.YY.225.104 (0x0306D80EE168)
*May 29 05:06:05.114: Vi1 IPCP: Event[Receive ConfReq+] State[REQsent to ACKsent]
*May 29 05:06:05.114: Vi1 PPP: old[Up] event[LocalTerm] state[Up]
*May 29 05:06:05.118: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up
*May 29 05:06:05.118: Vi1 PPP SIP segment: Update
*May 29 05:06:05.118: Vi1 PPP SIP segment:     if_number     0
*May 29 05:06:05.118: Vi1 PPP SIP segment:     sub_if_number 0
*May 29 05:06:05.118: Vi1 PPP SIP segment:     ppp_vencap    631BD24C
*May 29 05:06:05.118: Vi1 PPP SIP segment:     access id     0
*May 29 05:06:05.118: Vi1 PPP SIP segment:     switch hdl    0
*May 29 05:06:05.118: Vi1 PPP SIP segment:     sss circuit   0
*May 29 05:06:05.118: Vi1 PPP SIP segment:     lcp magic     62DD547C
*May 29 05:06:05.118: Vi1 PPP SIP segment:     local term    1
*May 29 05:06:05.118: Vi1 PPP SIP segment:     lcp up        1
*May 29 05:06:05.118: Vi1 PPP SIP segment:     punt to RP    0
*May 29 05:06:05.118: Vi1 PPP SIP segment:     cond debug    1
*May 29 05:06:05.118: Vi1 PPP SIP segment:     vp_bound      0
*May 29 05:06:05.118: Vi1 PPP SIP segment:     fwded         0
*May 29 05:06:05.122: Vi1 IPCP: I CONFNAK [ACKsent] id 1 len 10
*May 29 05:06:05.122: Vi1 IPCP:    Address XX.YY.231.205 (0x0306D80EE7CD)
*May 29 05:06:05.122: Vi1 IPCP: O CONFREQ [ACKsent] id 2 len 10
*May 29 05:06:05.122: Vi1 IPCP:    Address XX.YY.231.205 (0x0306D80EE7CD)
*May 29 05:06:05.122: Vi1 IPCP: Event[Receive ConfNak/Rej] State[ACKsent to ACKsent]
*May 29 05:06:05.130: Vi1 IPCP: I CONFACK [ACKsent] id 2 len 10
*May 29 05:06:05.130: Vi1 IPCP:    Address XX.YY.231.205 (0x0306D80EE7CD)
*May 29 05:06:05.130: Vi1 IPCP: Event[Receive ConfAck] State[ACKsent to Open]
*May 29 05:06:05.142: Vi1 IPCP: State is Open
*May 29 05:06:05.142: Di0 IPCP: Install negotiated IP interface address XX.YY.231.205
*May 29 05:06:05.146: Di0 Added to neighbor route AVL tree: topoid 0, address XX.YY.225.104
*May 29 05:06:05.146: Di0 IPCP: Route not installed to XX.YY.225.104

And relevant parts of the config:

interface ATM0/1/0
no ip address
dsl operating-mode auto
no sh
pvc 0/100
pppoe-client dial-pool-number 1
!
interface dialer0
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
no cdp enable
ppp authentication pap callin
ppp pap sent-username luser password xxXXxx
dialer pool 1
dialer-group 1
no sh
!
ppp ipcp dns request accept
ppp ipcp address accept
dialer-list 1 protocol ip permit
ip route 0.0.0.0 0.0.0.0 dialer0
!
interface FastEthernet0/0
shutdown
no ip address
!
interface FastEthernet0/1
ip add 192.168.2.1 255.255.255.0
ip nat inside
ip tcp adjust-mss 1452
no sh
!
access-list 100 permit ip 192.168.2.0 0.0.0.255 any
ip nat inside source list 100 interface dialer0 overload
!
!
ip dhcp pool Router
   network 192.168.2.0 255.255.255.0
   default-router 192.168.2.1
   dns-server 8.8.8.8 4.4.4.4
!

I can ping XX.YY.231.205 from the internal network, but not from the Cisco command line. I can't get out to the Internet from anywhere.

If someone can point me in the right direction of how to diagnose this, I would appreciate it.

3
  • Under step 9 of (this walkthrough: dslreports.com/faq/8199 ), I note that they set three ppp ipcp commands, or the ip route command alone as a fallback, and you have two of them set and the ip route command as well. Have you tried getting rid of ip route and adding ppp ipcp route default to Dialer0 (and shut/no shut it)? Jun 2, 2015 at 3:37
  • I have tried ppp ipcp route default with and without ip route. It still shows 'Default route is not set' when looking into show ip route * commands. Jun 2, 2015 at 3:56
  • This should be on the Network Engineering StackExchange website.
    – jwbensley
    Nov 25, 2016 at 12:03

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.