0

I'm running wordpress on a Digitalocean VPS with cloudflare installed. My ssl was working perfectly till a few days ago when a buch of clients informed me they received the following error when visiting the site (on chrome, it works on mozilla):

ERR_SSL_VERSION_OR_CIPHER_MISMATCH

A secure connection cannot be established because this site uses an unsupported protocol.

I've disabled sslv3 and sslv2 to no avail, and making changes to my cloudflare dash doesn't affect anything.

I've analyzed the site via ssl labs and everything is seemingly okay https://www.ssllabs.com/ssltest/analyze.html?d=saharacluster.com .

This error is very cryptic, you can see in the report that one simulated connection recreates the same error (via anndroid) however chrome seems to connect fine.

This has me very worried and I've disabled ssl on the site temporarily.

0

This is really hard to tackle here, but this could be some sort of anti-virus or firewall setting and/or a setting in the Chrome browser. CloudFlare hasn't really made any recent changes to our SSL that should cause a sudden uptick in SSL questions or concerns.

  • Its very frustrating but thanks :-) PS//I'm in a remote place sorry for the late reply – Jonathan Jun 17 '15 at 6:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.