3

I have a HP DL320e g8 v2 server running CentOS 7.1 (kernel 3.10.0-229.4.2.el7.x86_64). This server comes with a B120i onboard SmartArray controller, and it was configured with two identical 3TB Seagate disks in RAID-0. I've installed CentOS 7.1 minimal system, with XFS and bs=4096.

After system´s installation, I got theses rates to read and write:

dd if=/dev/zero of=test.img bs=4k count=2560000
2560000+0 records in
2560000+0 records out
10485760000 bytes (10 GB) copied, 25.4219 s, 412 MB/s

dd if=test.img of=test2.img bs=4k
2560000+0 records in
2560000+0 records out
10485760000 bytes (10 GB) copied, 413.832 s, 25.3 MB/s

dd if=test.img of=/dev/null bs=4k
2560000+0 records in
2560000+0 records out
10485760000 bytes (10 GB) copied, 400.053 s, 26.2 MB/s

As you can see, the WRITE rate is fast (about 400 MB/s), but the READ rate is very slow (about 25 MB/s). I've done two tests, first writing to another file and after writing to /dev/null... and in both cases the read rate is slow.

I get the same 25 MB/s read rate when coping a file from this server to another via NFS.

Somebody has any ideia about what could be happening?

I've tried using CentOS 6.6 and got the same results. This server will be a backup (bacula) server, and the disk read rate impacts the bacula performance...

Tks

  • 1
    RAID 0 for a backup server? – ewwhite Jun 3 '15 at 13:59
  • 1
    Do you have any cache on this RAID controller? – ewwhite Jun 3 '15 at 14:16
  • RAID0 because it's only for bacula spool... it's just to obtain 6TB. Not for permanent storage. – Elieser Topassi Jun 3 '15 at 15:02
  • Read cache is enabled, but write cache is disabled. I know bacula recomends use of write cache even the batery is not present, but I dont enabled it. – Elieser Topassi Jun 3 '15 at 15:04
  • How much RAM do you have there? Linux can buffer your write memory pages. Did you align partitions correctly? Do you have SATA ports on mainboard? Write speed is too fast for two disks. Something wrong here. Have you tried choose bigger block size when coping data using dd for example 1MiB? – Michal Sokolowski Jun 3 '15 at 20:00
0

Last sunday, I formatted and reinstalled SO using the B120i in AHCI mode. I've used the Linux MD for RAID, and I've got better results.

Now, the read rate is about 300 MB/s, and the copy rate from the disks to a LTO-4 tape is about 140 MB/s. It's copying 1 TB to tape in 2h30.

It's not the best solution (I would like to use the B120 RAID mode), but for now it's ok.

Thank you everybody.

0

I had same problems on HP Microserver G8 with same B120i controller. Seems that there are perfomance problems on newer drivers. Last hpvsa driver without these issues is 1.2.8-160, and the newest supported by it is CentOS is 6.5.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.