11

curl: /usr/local/lib/libcurl.so.4: no version information available (required by curl)

This is the error I am getting. This error has not stopped any scripts or apps from running or preforming their tasks, however I do get an email from the system also anytime curl is used.

I have cron jobs that run often. Some every few minutes, others longer and I get emails that will have that error line in it. I have googled the hell out of the string and variations of it. However, I am unable to find anything useful.

What I have done: Deleted the file /usr/local/lib/libcurl.so.4, this makes the error go away and curl still works with no issues. After about 24-48 hours, the file will come back, pop back up in to the folder and I will have to re-delete it. I know this is not the right thing to do, but I am not sure what else to do.


Contents of /usr/local/lib/

libcurl.a
libgcrypt.la
libgpg-error.la
libruby-static.a
python2.7/
weechat/
libcurl.la
libgcrypt.so
libgpg-error.so
node_modules/
python3.4/
libcurl.so
libgcrypt.so.20
libgpg-error.so.0
pkgconfig/
ruby/
libcurl.so.4.3.0
libgcrypt.so.20.0.3
libgpg-error.so.0.15.0
postsrsd/
site_ruby/

Installed Packages:

$ apt --installed list | grep 'curl'
curl/trusty-updates,trusty-security,now 7.35.0-1ubuntu2.5 amd64 [installed]
libcurl3/trusty-updates,trusty-security,now 7.35.0-1ubuntu2.5 amd64 [installed]
libcurl3-gnutls/trusty-updates,trusty-security,now 7.35.0-1ubuntu2.5 amd64 [installed]
libcurl4-openssl-dev/trusty-updates,trusty-security,now 7.35.0-1ubuntu2.5 amd64 [installed]
php5-curl/trusty-updates,trusty-security,now 5.5.9+dfsg-1ubuntu4.9 amd64 [installed]
python-pycurl/trusty,now 7.19.3-0ubuntu3 amd64 [installed,automatic]
python3-pycurl/trusty,now 7.19.3-0ubuntu3 amd64 [installed]

$ lsb_release -a
Distributor ID: Ubuntu
Description:    Ubuntu 14.04.2 LTS
Release:        14.04
Codename:       trusty

Anything to point me in the right direction would be much appreciated.

Edit #1 (more info) The link is aways made at 8:00:01am just after the daily cron job runs.

celestia@Canterlot:/usr/local/lib# ls -hal
drwxr-xr-x 10 celestia root  4.0K Jun 11 07:58 .
drwxr-xr-x 11 celestia root  4.0K Jun 23  2014 ..
-rw-r--r--  1 celestia root  805K May  2 00:16 libcurl.a
-rwxr-xr-x  1 celestia root   953 May  2 00:16 libcurl.la
lrwxrwxrwx  1 celestia root    16 May  2 00:16 libcurl.so -> libcurl.so.4.3.0
lrwxrwxrwx  1 celestia root    16 Jun 11 07:58 libcurl.so.4 -> libcurl.so.4.3.0
-rwxr-xr-x  1 celestia root  424K May  2 00:16 libcurl.so.4.3.0
-rwxr-xr-x  1 celestia root   987 May  2 00:20 libgcrypt.la
lrwxrwxrwx  1 celestia root    19 May  2 00:20 libgcrypt.so -> libgcrypt.so.20.0.3
lrwxrwxrwx  1 celestia root    19 May  2 00:20 libgcrypt.so.20 -> libgcrypt.so.20.0.3
-rwxr-xr-x  1 celestia root  3.5M May  2 00:20 libgcrypt.so.20.0.3
-rwxr-xr-x  1 celestia root   956 May  2 00:13 libgpg-error.la
lrwxrwxrwx  1 celestia root    22 May  2 00:13 libgpg-error.so -> libgpg-error.so.0.15.0
lrwxrwxrwx  1 celestia root    22 May  2 00:13 libgpg-error.so.0 -> libgpg-error.so.0.15.0
-rwxr-xr-x  1 celestia root  336K May  2 00:13 libgpg-error.so.0.15.0
celestia@Canterlot:/usr/local/lib# stat libcurl.so.4
  File: ‘libcurl.so.4’ -> ‘libcurl.so.4.3.0’
  Size: 16              Blocks: 0          IO Block: 4096   symbolic link
Device: fc00h/64512d    Inode: 30939991    Links: 1
Access: (0777/lrwxrwxrwx)  Uid: (    0/celestia)   Gid: (    0/    root)
Access: 2015-06-11 08:00:01.983201467 -0400
Modify: 2015-06-11 07:58:17.551455525 -0400
Change: 2015-06-11 07:58:17.551455525 -0400
 Birth: -

celestia@Canterlot:/usr/local/lib# apt-file search libcurl.so.4
libcurl3: /usr/lib/x86_64-linux-gnu/libcurl.so.4
libcurl3: /usr/lib/x86_64-linux-gnu/libcurl.so.4.3.0

celestia@Canterlot:/usr/local/lib# ldd libcurl.so.4
linux-vdso.so.1 =>  (0x00007fff1cdfe000)
libssl.so.1.0.0 => /lib/x86_64-linux-gnu/libssl.so.1.0.0 (0x00007fb2e75f1000)
libcrypto.so.1.0.0 => /lib/x86_64-linux-gnu/libcrypto.so.1.0.0 (0x00007fb2e7216000)
libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007fb2e6ffc000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fb2e6c37000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fb2e6a33000)
/lib64/ld-linux-x86-64.so.2 (0x00007fb2e7ad2000)
8
  • 1
    Your system is probably compromised. – Michael Hampton Jun 4 '15 at 18:09
  • That could be, though I have looked into that and have not seen anything running that I have not put in place or anything else weird. I know this is a possibility, but I would think it is more likely to be another app, or curl, or something that would cause this. If I could find what is making the file, it would be start, but I am not able to. I do know the file is remade most mornings at 8am when the cron.daily is run. – Dasoren Jun 4 '15 at 20:24
  • 1
    Files don't just appear, except on compromised systems. Try running checkrootkit. – Wouter Verhelst Jun 11 '15 at 13:51
  • @Wouter Verhelst Ran, nothing found/not infected – Dasoren Jun 11 '15 at 14:13
  • Do you cron automatic security updates? Do you have any custom packages either from a third party repository, or one you compiled yourself? Have you installed any software from source? – brent Jun 11 '15 at 14:43
11

The issue turned out to be I had 2 installs of curl on the system. An apt-get install curl and a curl build from source. I ended up removing the curl built from source and everything works fine now. I also tried later removing the apt-get one and rebuilding curl from source again and all was good. But when I reinstalled the curl from apt-get with the source one still installed, the same issue started again. So I removed the apt-get one again.

In short do not have curl on the system twice, issues happen then.

Sorry if this is not well written, I just got up.

1
  • 2
    How did you remove one? – agrublev Apr 14 '17 at 2:15
5

I also had such problem in installing CMAKE, I type cmake, the output is:

cmake: /usr/local/lib/libcurl.so.4: no version information available     (required by cmake)
Segmentation fault (core dumped)`

Something like yours.I fixed it like this:

sudo ln -fs /usr/lib/libcurl.so.4 /usr/local/lib/

Then, I type cmake -version, and the result is

cmake version 3.2.2

CMake suite maintained and supported by Kitware (kitware.com/cmake).
0

before that check this $ldd curl for any missing linked libraries if found missing then add this line "/usr/local/lib" in /etc/ld.so.conf and run $sudo ldconfig -v the check $ldconfig -p then curl must be able to use missing lib from this directory

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.