1

Here is my firewall settings:

Firewall settings

Clearly, firewall is on for both private and public networks and it is set to "Block all connections including programs on the list of allowed programs". I did not explicitly add TeamViewer to the list and I would expect that using TeamViewer to remote desktop into a computer with these firewall settings would not work - firewall would stop TeamViewer from making the connection. But firewall did not stop TeamViewer - it went right around the firewall (without so much as a notification). How do they do this? How do I make my software capable of doing this?

1

You would need to add an outbound rule to block teamviewer. This would stop teamviewer establishing a connection with the teamviewer servers.

Teamviewer connects to central servers using outbound connections the connection is established inside your firewall, so your incoming firewall rules don't make any difference.

  • So if I sent a packet out to someone and they reply from their address back to me within a short period of time, the firewall will not block that? – Sacha T Red Jun 4 '15 at 16:40
  • Isn't that exactly what some NATs do? Cone restrictive NAT or something like that? – Sacha T Red Jun 4 '15 at 16:40
  • Yes and no, you can NAT in either direction and apply a firewall rule in either direction. Restricted Cone NAT could be used but then block connections to a particular IP. That wouldn't be blocking that type of NAT rather the source/destination/type etc... – Drifter104 Jun 4 '15 at 16:46
  • I noticed that I have inbound rules enabled for C:\Program File (x86)\Skype\Phone\Skype.exe and for C:\Program File (x86)\TeamViewer.exe and TeamViewer_Service.exe (UDP and TCP), but neither of those Programs is listed in the Outbound Rules. – Sacha T Red Jun 4 '15 at 16:49
  • Does that mean that with the given rules, Skype and TeamViewer can send UDP and TCP packets to me without me having to send them a UDP packet first? – Sacha T Red Jun 4 '15 at 16:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.