5

I followed the first part from the tutorial here to install Elasticsearch. I didn't install java because I already have that installed with other java programs running.

sudo service elasticsearch restart

Doesn't output anything.

sudo service elasticsearch status

Outputs the following:

● elasticsearch.service - Starts and stops a single elasticsearch instance on this system Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; disabled; vendor preset: enabled) Active: failed (Result: exit-code) since Sat 2015-06-06 08:33:20 EET; 1s ago Docs: http://www.elasticsearch.org Process: 17111 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -Des.default.config=$CONF_FILE -Des.default.path.home=$ES_HOME -Des.default.path.logs=$LOG_DIR -Des.default.path.data=$DATA_DIR -Des.default.path.work=$WORK_DIR -Des.default.path.conf=$CONF_DIR (code=exited, status=3) Main PID: 17111 (code=exited, status=3)

Jun 06 08:33:20 mohammed-xubuntu elasticsearch[17111]: ... 4 more Jun 06 08:33:20 mohammed-xubuntu elasticsearch[17111]: log4j:WARN No appender... Jun 06 08:33:20 mohammed-xubuntu elasticsearch[17111]: log4j:WARN Please init... Jun 06 08:33:20 mohammed-xubuntu elasticsearch[17111]: log4j:WARN See http://... Jun 06 08:33:20 mohammed-xubuntu elasticsearch[17111]: {1.5.2}: Initializatio... Jun 06 08:33:20 mohammed-xubuntu elasticsearch[17111]: - ElasticsearchIllegal... Jun 06 08:33:20 mohammed-xubuntu elasticsearch[17111]: AccessDeniedException[... Jun 06 08:33:20 mohammed-xubuntu systemd1: elasticsearch.service: main pro...D Jun 06 08:33:20 mohammed-xubuntu systemd1: Unit elasticsearch.service ente.... Jun 06 08:33:20 mohammed-xubuntu systemd1: elasticsearch.service failed. Hint: Some lines were ellipsized, use -l to show in full.

It says I should pass -l option somewhere to get the full output though I don't know where exactly.

5

This is a known issue with Elasticsearch on Ubuntu 15.04. There is a GitHub issue. The temporary fix:

As a workaround you can uncomment the paths in the /etc/default/elasticsearch file and it should work.

| improve this answer | |
0

On Ubuntu 15.10, in addition to uncommenting the DIRS I also had to uncomment START_DAEMON to true on /etc/default/elasticsearch to get it to start.

| improve this answer | |
0

I found that the rc.d symlinks were not installed, even when installing using elastic.co packages. Also disabling systemd for elasticsearch/

I ran the following:

update-rc.d elasticsearch defaults
update-rc.d logstash defaults
update-rc.d kibana defaults
systemctl disable elasticsearch
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.