We have an on premise Exchange 2013 server. When sending email with large attachments from ActiveSync accounts on IOS devices, the email gets stuck in the outbox and won't send. It keeps trying to resend and can cause our users to blow their data allowance and start costing hundreds in data fees. It does not do this when sending from a Gmail account linked on the phone, or from a windows 8 phone.

I've narrowed down an attachment size of about 7660870 bytes before the issue starts occurring. For a few bytes over this limit, the email will have a failure message, but will still be sent through without the attachment. If you add a few more bytes on, we get the failure message but no email goes through and it gets stuck in the outbox. These sizes are under our allowed size limits for internal and external mail. Additionally, I'm guessing the behavior of this issue depends on the total size of the message including header, body, etc., not just the attachments.

Has anyone seen this happen before, or have any idea what could be causing this?

  • 1
    Something doesn't make sense. If they are using up their data allowance then it would suggest the data is at least leaving the phone, but just not completing – Drifter104 Jun 12 '15 at 11:20
  • Yeah, we're confused by it. If I don't get any luck soon, I'm going to bite the bullet and pay Microsoft the $500 to get some support. – eltommo Jun 16 '15 at 3:31
  • It is stuck on the outbox of the phone and not the user's exchange mailbox correct? – IceMage Jun 17 '15 at 19:49
  • Also, sometimes the cell carrier can set limitations such as these, check the log files on the exchange server to see if the message could be getting cut off due to network management practices by the carrier. – IceMage Jun 17 '15 at 19:51

Take a look at https://technet.microsoft.com/en-gb/library/hh529949(v=exchg.150).aspx

There is an interesting line at the bottom of that page that implies the effective maximum limit is about 33% less then the limit you have configured. Given the default for active sync is 10mb and you are seeing problems around 7, that would make sense.

Try increasing to 20mb and see if that makes a difference.

  • Interesting. I've come across this article so many times but somehow managed to miss this part. I'll have a go at bumping up all the values and see what happens. – eltommo Jun 15 '15 at 2:51
  • I've tried increasing all the 1024 values by a factor of 10 and ran iisreset. Still not luck :( – eltommo Jun 16 '15 at 3:30
  • Got it working. I decided to re-check the web.config file in both those locations from the document. For some stupid reason I still had the maxRequestLength="10240" in %ExchangeInstallPath%ClientAccess\Sync\web.config. I don't know what stupid thing I did to not change it the first time, but I bumped it up and now it's working. Thank you for this, I'm overjoyed to see it finally working! You get the bounty. – eltommo Jun 18 '15 at 1:18
  • Glad you got it sorted. – Drifter104 Jun 18 '15 at 18:49

Try increasing the uploadReadAheadSize in IIS as in the following example (change the size to the one that you need):

C:\Windows\System32\inetsrv\appcmd.exe set config -section:system.webServer/serverRuntime /uploadReadAheadSize:"10485760" /commit:apphost

C:\Windows\System32\inetsrv\appcmd.exe set config "Default Web Site" -section:system.webServer/serverRuntime /uploadReadAheadSize:"10485760" /commit:apphost

Or directly from the IIS management tool:

enter image description here

  • I changed the value to 25M and restarted IIS. Still no success unfortunately. – eltommo Jun 8 '15 at 8:16

This doesn't seem to affect just IOS, it may be that your carrier (or carrier settings for your phone) is cutting off the message during the send, meaning that an error isn't coming from the Exchange server to the iPhone, so your iPhones are trying over and over again.

Try reducing the data cap to something like 7340032 (7 MB) or 6291456 (6 MB) and see if your phones at least stop trying to send the email. The major issue here wouldn't be that the phones can't send the email, it's that they don't stop trying and kill the battery and data plan.

  • I've tested the issue on both the 3G network and our wifi to check this. Same result for both, so I don't think it's a carrier issue. – eltommo Jun 18 '15 at 0:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.