1

I launched an AWS instance with Ubuntu 14.04.

I connected to the instance via terminal and I installed the apache2 server as follows:

sudo apt-get update sudo apt-get install apache2

I made sure that the apache2 server is running by running:

sudo service apache2 start

But when I try to connect to the web site to see if it's working, as follows:

http://xxx.xxx.xxx.xxx

I get an error message:

This webpage is not available

Per the instructions I read, I should be seeing a default web page. Any ideas?

  • 1
    Stop using Internet Explorer. Its "error messages" are utterly worthless. – Michael Hampton Jun 8 '15 at 17:28
  • 2
    Did you open port 80 on your security groups? – ceejayoz Jun 8 '15 at 17:36
  • @MichaelHampton Chrome's error message for a name resolution error is "This webpage is not available". How do you know they're on IE? i.stack.imgur.com/yObl8.png – ceejayoz Jun 8 '15 at 17:37
  • 1
    Like @ceejayoz mentioned, you need to make sure port 80 is open in your AWS security group for that server. I'd also check and see if the OS firewall is running and if that port is blocked. I think the command "sudo ufw status verbose" will tell you on Ubuntu. If it's active, make sure to allow port 80. "sudo ufw allow 80" – OrganizedChaos Jun 8 '15 at 17:52
1

Assuming your apache is configured properly and listening on port 80 (check with lsof -i or netstat), then you probably have an access control problem since layer 3 is good (you can route to it properly via ssh).

1) Check your Network ACL settings within the VPC resource on AWS. Ensure that inbound allows port 80. The default allows all so this is probably not the problem

2) Check your security group. You are allowing SSH, however you are not allowing port 80. Check the security group(s) that are associated with your instance. This is most likely where your problem is since people (including myself) sometimes forget to correctly configure these.

3) Check your server itself; it is possible your server is blocking port 80. Check IPTables.

What you do know for sure is that layer 3 is good. Highly probable that your problem is either a) access control or b) you did not install/configure apache correctly.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.