1

goodmorning my friends, this is my situation: I have two debian servers with static IP connected through a site to site VPN OPENSWAN, everything works like a charm, I can ping the entire lan from any workstations and transfer performance is very good. But what happens is that randomly(it can be 2 times in a day or one in 2 weeks) the VPN goes down. If I launch /etc/init.d/ipsec status I got that the tunnel is up but VPN is not working. Only solution is to launch /etc/init.d/ipsec restart or on some cases I need to reboot the routers. Anyone have some suggestions? or at last I just want to got a log somewhere but I can't find anything useful!

local ip server left is 192.168.0.100/24 and right is 192.168.1.100/24

for my privacy public ip server left is 111.222.333.555 and right is 111.222.333.444

this is my ipsec.conf on left

config setup
        #dumpdir=/var/run/pluto/
        #forwardcontrol=yes
        nat_traversal=yes
        protostack=netkey
        #virtual_private=%v4:10.0.0.0/8,%v4:172.16.0.0/12,%v4:25.0.0.0/8,%v6:fd00::/8,%v6:fe80::/10
        # Use this to log to a file, or disable logging on embedded systems (like openwrt)
        #plutostderrlog=/dev/null
        #oe=off
        interfaces=%defaultroute
        #klipsdebug=all
        plutodebug=all
conn tunnel
        left=192.168.0.100 <-- left local ip
        leftid=@server1.mydomain.it
        leftrsasigkey=#####################################
        leftsubnet=192.168.0.0/24
        leftsourceip=192.168.0.100
        right=111.222.333.444 <-- right static ip
        rightid=@server2.mydomain.it
        rightrsasigkey=#####################################
        rightsubnet=192.168.1.0/24
        rightsourceip=192.168.1.100
        auto=start

and this is my ipsec.conf on right

config setup
        #dumpdir=/var/run/pluto/
        #forwardcontrol=yes
        nat_traversal=yes
        protostack=netkey
        #virtual_private=%v4:10.0.0.0/8,%v4:172.16.0.0/12,%v4:25.0.0.0/8,%v6:fd00::/8,%v6:fe80::/10
        # Use this to log to a file, or disable logging on embedded systems (like openwrt)
        #plutostderrlog=/dev/null
        #oe=off
        interfaces=%defaultroute
        #klipsdebug=all
        plutodebug=all
conn tunnel
        left=111.222.333.555 <-- left static ip
        leftid=@server1.mydomain.it
        leftrsasigkey=#####################################
        leftsubnet=192.168.0.0/24
        leftsourceip=192.168.0.100
        right=192.168.1.100 <-- right local ip
        rightid=@server2.mydomain.it
        rightrsasigkey=#####################################
        rightsubnet=192.168.1.0/24
        rightsourceip=192.168.1.100
        auto=start

debian is 7 and openswan is last version Openswan U2.6.37/K3.2.0-4-amd64

ipsec verify doesn't give me errors many thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.