0

I try to create an instance with a local attached SSD on GCE. I used the command from the docs:

gcloud compute instances create foobz \
     --machine-type n1-standard-8 \
     --zone us-central1-f \
     --local-ssd interface=nvme \
     --local-ssd interface=nvme \
     --image nvme-backports-debian-7-wheezy-v20141108 \
     --image-project gce-nvme

result:

ERROR: (gcloud.compute.instances.create) Some requests did not succeed:
 - Invalid value for field 'resource.diskTypes': 'projects/xxx/zones/us-central1-f/diskTypes/local-ssd'.  Resource was not found.

My gcloud is up to date

gcloud version
Google Cloud SDK 0.9.64

alpha 2015.06.02
bq 2.0.18
bq-nix 2.0.18
compute 2015.06.09
core 2015.06.09
core-nix 2015.06.02
dns 2015.06.02
gcloud 2015.06.09
gcutil 1.16.5
gcutil-msg 2015.06.09
gsutil 4.13
gsutil-nix 4.12
kubectl
kubectl-darwin-x86_64 0.18.1
preview 2015.06.09
sql 2015.06.09

I run OSX. Did I forget something?

  • What did Google support say about this? – EEAA Jun 11 '15 at 13:38
  • 1
    The command is good. If you run it from a GCE linux machine it will work. I'll try to test it on a OS X computer tomorrow. – Kamran Jun 11 '15 at 18:45
  • @EEAA well... the support is pointing to servervault or Google Groups – soupdiver Jun 12 '15 at 9:42
  • 1
    I tested the command on Mac OS X and it worked. did you try this command from a GCE VM instance to make sure the issue is not related to your project? – Kamran Jun 15 '15 at 2:39
1

My account was a trial account. It seems SSDs are only available for full accounts.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.