2

I have some problems with installing or upgrading anything on Centos 6.6. Problem is pretty much summed up in the topic name. When i try:

yum install gcc-c++

I get:

...
Error:  Multilib version problems found. This often means that the root
   cause is something else and multilib version checking is just
   pointing out that there is a problem. Eg.:

     1. You have an upgrade for libgomp which is missing some
        dependency that another package requires. Yum is trying to
        solve this by installing an older version of libgomp of the
        different architecture. If you exclude the bad architecture
        yum will tell you what the root cause is (which package
        requires what). You can try redoing the upgrade with
        --exclude libgomp.otherarch ... this should give you an error
        message showing the root cause of the problem.

     2. You have multiple architectures of libgomp installed, but
        yum can only see an upgrade for one of those arcitectures.
        If you don't want/need both architectures anymore then you
        can remove the one with the missing update and everything
        will work.

     3. You have duplicate versions of libgomp installed already.
        You can use "yum check" to get yum show these errors.

   ...you can also use --setopt=protected_multilib=false to remove
   this checking, however this is almost never the correct thing to
   do as something else is very likely to go wrong (often causing
   much more problems).

   Protected multilib versions: libgomp-4.4.7-3.el6.i686 != libgomp-4.4.7-11.el6.x86_64
Error: Protected multilib versions: libstdc++-4.4.7-3.el6.i686 !=libstdc++-4.4.7-11.el6.x86_64
Error: Protected multilib versions: libgcc-4.4.7-3.el6.i686 != libgcc-4.4.7-11.el6.x86_64
Error: Protected multilib versions: cpp-4.4.7-3.el6.i686 != cpp-4.4.7-11.el6.x86_64

And this problem doesn't allow me to make any install on the system. As I am a server newbie - i spent already around 3 hours working on that problem - not any thing suggested i found so far seemed to work. Any ideas how to fix it?

Updates 1 & 2:

1)

uname -a 
... 2.6.32-504.16.2.el6.x86_64 #1 SMP Wed Apr 22 06:48:29 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux      

2)

yum repolist all
Loaded plugins: fastestmirror, security
Loading mirror speeds from cached hostfile
repo id                 repo name                                 status
base-BerM               centos6-base-bercut-mirror                enabled: 4,802
extras-BerM             centos6-extras-bercut-mirror              enabled:    13
update-BerM             centos6-updates-bercut-mirror             enabled: 1,155
repolist: 5,970    
  • Did you install i686 or x86_64 version of CentOS? You can see this in the output of uname -a – brent Jun 11 '15 at 13:04
  • x86_64. uname -a ... 2.6.32-504.16.2.el6.x86_64 #1 SMP Wed Apr 22 06:48:29 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux – dishonorableDeath Jun 11 '15 at 13:10
  • Do you have alternative repos like EPEL set up? – brent Jun 11 '15 at 13:47
  • No, I don't. yum repolist all Loaded plugins: fastestmirror, security Loading mirror speeds from cached hostfile repo id repo name status base-BerM centos6-base-bercut-mirror enabled: 4,802 extras-BerM centos6-extras-bercut-mirror enabled: 13 update-BerM centos6-updates-bercut-mirror enabled: 1,155 repolist: 5,970 – dishonorableDeath Jun 11 '15 at 13:54
  • What are these "bercut-mirror" repos? – Michael Hampton Jun 11 '15 at 17:04
2

Recommendation from RHN is to downgrade the packages:

yum downgrade libgomp
yum downgrade libstdc++
yum downgrade libgcc
yum downgrade cpp

Source: https://access.redhat.com/solutions/196103 (Answer visible to RHN subscribers)

  • Nothing to do at all positions. – dishonorableDeath Jun 15 '15 at 10:36
  • Works like a charm. Although I only donwgrade libgomp to resolve the problem. – zack Apr 25 '16 at 9:23
0

I usually get this when updating a 64-bit package that has the equivalent 32-bit package installed, but the 32-bit update package doesn't exist, perhaps because the 32-bit channel isn't subscribed, or maybe the current channel doesn't have updated 32-bit channels. If I don't need the 32-bit version, I remove it and then try the update.

  • the 32-bit packages are "available, but not installed". It wants to use 32-bit packages, but i have x86_64 installed, as i understood so far. I just don't understand - why it insists on using i686 on x86_64 system and is there any workaround. – dishonorableDeath Jun 15 '15 at 11:00
  • It is possible that a dependency has a 32-bit package installed also. I know, it is kind of a hassle. – lsd Jun 15 '15 at 11:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.