1

On the Icinga instance I look after some of the service checks aren't running on the schedule they should be. Moreover when I try to schedule a manual check I get the error message

Logger "4294967296" has not been configured.

The log file contains the folowing.

[Thu Jun 11 19:35:38 2015] [debug] Setting up console for instance default (Cronks_System_CommandSenderModel::getConsoleInstance(), line 79)

[Thu Jun 11 19:35:38 2015] [debug] Submitting command SCHEDULE_FORCED_SVC_CHECK to {"host":" test.example.net","service":"HTTP","instance":"default"} (Cronks_System_CommandSenderModel::dispatchCommands(), line 69)

[Thu Jun 11 19:35:38 2015] [info] Sending command failed Logger "4294967296" has not been configured.

Does anyone have any idea what this issue is?

  • You shouldn't guess nor speak that harsh - it doesn't help anyone (maybe you and your anger, but not long enough). We've seen the issue and are discussing it offline (it is vacation time as well). In terms of packages - join the team, add your feedback directly and be a hero for anyone else gaving the same issue. – dnsmichi Jun 12 '15 at 16:48
  • I've installed the classic UI in standalone mode so that I have a usable icinga instance – Phil Jun 12 '15 at 18:05
  • @dnsmichi I have deleted my comment. Still it is an horrible idea to have only the latest version in the repo is very bad. Icingaweb is staying only until icingaweb2 is stable enough for our needs, I would have happily rolled back and forgot about this issue – Bruno9779 Jul 3 '15 at 18:12
  • @Bruno9779 I don't think this is the right place to discuss this further. Contact the team, or create a referencing issue. icinga.org/community/get-involved – dnsmichi Aug 29 '15 at 10:24
0

Seems someone else has reported a bug with a similar error to their dev. https://dev.icinga.org/issues/9323

Have you tried restarting syslog and do the permissions appear to be ok?

  • Thanks for that bug report. I've tried restarting icinga, ido2db & the entire machine but none of those attempts worked. Permissions of what? – Phil Jun 11 '15 at 21:42
  • Im not certain what it might be, I would grep for 4294967296 inside the xml/conf to see if that is configured somewhere and check the permissions on that. – chrisw9808 Jun 11 '15 at 21:59
  • It appears in app/modules/AppKit/lib/logging/AppKitLogger.class.php defined as const COMMAND = 4294967296; However, it isn't used anywhere else in that file, and greping for COMMAND has the predictable result. – Phil Jun 12 '15 at 8:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.