Server: CentOS 7
NFS root filesystem for client and Kernel: Slackware 14.1

I enabled "Root file system on NFS" and "IP: kernel level autoconfiguration" with "DHCP,BOOTP,RARP" support, recompiled the Kernel(3.10.17).

TFTP,NFS,DHCP all ready.
I ensure that NFS can be mounted by a linux client.(mount -t nfs ... )
DHCP and TFTP worked properly, and I can boot from an isolinux kernel use ram root filesystem.

Now, I need a diskless node so I need the kernel to mount a root filesystem via NFS.

kernel kernels/vmlinuz
append ip=dhcp root=/dev/nfs nfsroot=,nfsvers=3 raid=noautodetect

I get the error when boot

VFS: Unable to mount root fs via NFS, trying floppy.

Also, it seems the kernel didn't get an ipaddress by DHCP when boot.
(No information about displayed, ether I use "ip= ... :eth0" manually)

As the Slackware use huge-kernel, so I don't have an initrd image.(Problem may be here?)(My Computer's Linux didn't have ether, and works properly :) )

Or may be some option in kernel menuconfig I didn't select :( .(and I really need to know it)


I was having the same problem as you and I was able to find a solution. I'm also using Slackware 14.1 and the huge kernel.

My problem was that the huge kernel doesn't include the Ethernet driver, in my case, the e1000 driver was compiled as a module in the huge.s kernel, I thought that all drivers were included with this kernel, my assumption was wrong. Once I added the e1000 driver into the kernel (not as a module) everything started to work, and I was able to mount the root with NFS.

You should see something like this before the VFS mount message:

[    3.325468] e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
[    3.337383] Sending DHCP requests ., OK
[    3.340259] IP-Config: Got DHCP answer from, my address is
[    3.340870] IP-Config: Complete:
[    3.341128]      device=eth0, hwaddr=08:00:27:c0:3e:a7, ipaddr=, mask=, gw=
[    3.341682]      host=test, domain=, nis-domain=(none)
[    3.341989]      bootserver=, rootserver=, rootpath=
[    3.342198]      nameserver0=
[    3.342816] md: Skipping autodetection of RAID arrays. (raid=autodetect will force)
[    3.382613] VFS: Mounted root (nfs filesystem) readonly on device 0:13.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.