1

I am still new at this, so please be gentle.

My company recently got our accounting department a small Cisco 877W router so that they can connect to the Internet via DSL. The 877W is setup with DHCP that give IP's in the 192.168.1.0/24 range.

Everything is working fine as the computers/laptops connect wirelessly to the router and can breakout to the Internet. They can also see each other and share files across this 192.168.1.0/24 network.

The issue is, they still need to access company resources on the company network such as servers, printers, etc. The company network range is 172.16.10.0/24 which is also DHCP.

What configuration need to be done on the 877W for them to stay on the Internet and 192.168.1.0/24 network but at the same time access the Company LAN 172.16.10.0/24 without disconnecting and re-connecting wirelessly to the Company Network?

I was thinking if adding another vlan (vlan2) and also bridge it (bvi2) to 172.16.10.0/24 network and then add a route to it (ip route 172.16.10.0 255.255.255.0 192.168.1.0) and an ACL (access-list 100 permit ip 172.16.10.0 0.0.0.255 any). Will this work?

I have included an output of the current 877W config below.

ip dhcp excluded-address 192.168.1.254
!
ip dhcp pool LAN
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.254
 dns-server 8.8.8.8 192.168.1.254
!
!
no ip bootp server
ip domain lookup source-interface ATM0
ip domain name domain.local
ip name-server 8.8.8.8
ip ssh time-out 60
ip ssh version 2
!
!
!
!
no spanning-tree vlan 1
username XXXXXXXX secret 5 XXXXXXXX
archive
 log config
  hidekeys
!
!
no crypto isakmp enable
!
bridge irb
!
!
interface Loopback0
 no ip address
!
interface ATM0
 no ip address
 load-interval 30
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0.1 point-to-point
 pvc 8/35
  pppoe-client dial-pool-number 1
 !
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Dot11Radio0
 description WLAN
 no ip address
 !
 encryption mode ciphers tkip
 !
 ssid XXXXXXXX
    authentication open
    authentication key-management wpa
    guest-mode
    wpa-psk ascii XXXXXXXX
 !
 speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0 basic-12.0 basic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
 station-role root
 no cdp enable
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
interface Vlan1
 no ip address
 ip mtu 1452
 ip tcp adjust-mss 1412
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface Dialer0
 ip address negotiated
 no ip redirects
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 ip route-cache flow
 ip tcp adjust-mss 1452
 load-interval 30
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication pap callin
 ppp pap sent-username XXXXXXXX password XXXXXXXX
!
interface BVI1
 ip address 192.168.1.254 255.255.255.0
 ip mtu 1452
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1412
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
!
no ip http server
no ip http secure-server
ip nat inside source list 100 interface Dialer0 overload
ip dns server
!
ip access-list standard VTY
ip access-list standard access
!
logging facility local6
access-list 100 permit ip 192.168.1.0 0.0.0.255 any
dialer-list 1 protocol ip permit
no cdp run
!
control-plane
!
bridge 1 route ip

As you can see, there is currently only connectivity to the Internet and no other routes.

I would appreciate any information.

Thank you

  • 1
    Please describe the rest of the network. – Michael Hampton Jun 12 '15 at 18:15
  • Hi, the company network are connected to switches which are then connected to firewalls. The accounts department are only connected to the 877W. – foomy Jun 13 '15 at 8:01
  • Are the two networks on the same ethernet/VLAN, or not? – Konrad Gajewski Jun 13 '15 at 12:06
  • Hi Konrad, the 877W is separate from the company LAN but it is connected to a switch on the company network. – foomy Jun 13 '15 at 12:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.