-1

I'm using webmin and postfix to send emails, and I can't send emails, I checked the logs in the file: /var/log/maillog anf found the following error:

fatal: specify a password table via the `smtp_sasl_password_maps' configuration parameter

how can I fix that.

4

Came across the same thing while we were beefing up our security. We used Webmin to track changes. On the "SMTP Authentication And Encryption" page, the "Use SASL SMTP authentication?" option when 'Yes' is selected inserts smtp_sasl_auth_enable = yes and it should be smtpd_sasl_auth_enable = yes. You will need to manually edit the main.cf file, either via the Webmin interface or cli.

  • This is exactly what i was trying to say :) – user1928596 Aug 13 '15 at 13:00
3

After sone googling I found the solution which was typo (made by postfix or webmin) smtp_sasl_password_maps which should have been smtpd_sasl_password_maps hope it helps someone else.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.